Bug 1298848 - [RFE] Centralized topology management
Summary: [RFE] Centralized topology management
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords: FutureFeature
: 1031852 (view as bug list)
Depends On: 1199516 1206588
Blocks: 1292074 1296125 1313485 1337808
TreeView+ depends on / blocked
 
Reported: 2016-01-15 09:23 UTC by Petr Vobornik
Modified: 2016-11-04 05:49 UTC (History)
7 users (show)

Fixed In Version: ipa-4.4.0-1.el7
Doc Type: Release Note
Doc Text:
Enhanced IdM topology management Information about the Identity Management (IdM) topology is now maintained at a central location in the shared tree. As a result, you can now manage the topology from any IdM server using the command line or the web UI. Additionally, some topology management operations have been simplified, notably: * Topology commands have been integrated into the IdM command-line interface, so that you can perform all replica operations using the native IdM command-line tools. * You can manage replication agreements in the web UI or from the command line using a new and simplified workflow. * The web UI includes a graph of the IdM topology, which helps visualize the current state of replica relationships. * IdM includes safety measures that prevent you from accidentally deleting the last certificate authority (CA) master from the topology or isolating a server from the other servers. * Support for server roles as a simpler way of determining which server in the topology hosts which services as well as installing these services onto a server. For details, see https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Linux_Domain_Identity_Authentication_and_Policy_Guide/index.html#managing-topology Note that the new functionality requires raising the domain level to `1`. See https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Linux_Domain_Identity_Authentication_and_Policy_Guide/index.html#domain-level
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 05:49:35 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tkt_5181.log (3.57 KB, text/plain)
2016-08-20 17:03 UTC, Abhijeet Kasurde
no flags Details
tkt_5689.log (3.43 KB, text/plain)
2016-08-20 17:26 UTC, Abhijeet Kasurde
no flags Details
tkt_5840.log (13.28 KB, text/plain)
2016-08-22 05:07 UTC, Abhijeet Kasurde
no flags Details
tkt_5867.png (82.92 KB, image/png)
2016-08-22 08:37 UTC, Abhijeet Kasurde
no flags Details
tkt_5906.png (69.03 KB, image/png)
2016-08-22 08:42 UTC, Abhijeet Kasurde
no flags Details
tkt_5967.png (74.46 KB, image/png)
2016-08-22 08:46 UTC, Abhijeet Kasurde
no flags Details
tkt_4987.log (1.27 KB, text/plain)
2016-08-22 09:00 UTC, Abhijeet Kasurde
no flags Details
tkt_5411.log (628 bytes, text/plain)
2016-08-22 09:09 UTC, Abhijeet Kasurde
no flags Details
tkt_5588.log (3.59 KB, text/plain)
2016-08-22 09:34 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-01-15 09:23:48 UTC
Description of problem:

As an Administrator I want to manage the IdM Server replication topology from a central location via CLI or UI, so that I can overview the configured topology and easily do changes to the replication agreements of the main or CA database.

Upstream design: http://www.freeipa.org/page/V4/Manage_replication_topology

Comment 3 Petr Vobornik 2016-02-19 13:48:05 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5181

Comment 4 Petr Vobornik 2016-02-19 13:48:11 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5689

Comment 5 Petr Vobornik 2016-02-19 13:48:14 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5588

Comment 6 Petr Vobornik 2016-02-19 13:48:16 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5411

Comment 7 Petr Vobornik 2016-02-19 13:48:18 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4987

Comment 8 Martin Kosek 2016-02-25 14:51:17 UTC
*** Bug 1031852 has been marked as a duplicate of this bug. ***

Comment 9 Martin Kosek 2016-02-25 14:55:05 UTC
Bug 1031852 should be inherently solved by this feature and the CLEANALLRUV improvements (details in the bug).

Comment 10 Petr Vobornik 2016-04-28 14:28:11 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5840

Comment 12 Petr Vobornik 2016-05-05 10:59:20 UTC
Ticket https://fedorahosted.org/freeipa/ticket/5411 is more related to bug 1212713 than to this general ticket. Consider to test it in that bug.

Comment 13 Petr Vobornik 2016-05-10 14:43:41 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5867

Comment 15 Petr Vobornik 2016-05-17 15:46:21 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5883

Comment 16 Petr Vobornik 2016-05-17 15:46:31 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5884

Comment 17 Petr Vobornik 2016-06-02 13:02:33 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5906

Comment 24 Petr Vobornik 2016-06-21 12:23:50 UTC
Unlinking #5883 and #5884:
* topology graph: Add background to the canvas to improve UX
* topology graph: add buttons for zooming the canvas

They are only UX enhancements which won't be addresses in 4.4 upstream release. They don't solve any additional use cases.

Comment 26 Petr Vobornik 2016-06-22 16:39:23 UTC
Moving to assinged, due to #5967

Comment 27 Petr Vobornik 2016-06-22 16:40:02 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5967

Comment 28 Martin Kosek 2016-06-27 06:10:30 UTC
All currently linked upstream tickets are fixed. Moving to POST.

Comment 33 Abhijeet Kasurde 2016-08-20 17:03 UTC
Created attachment 1192481 [details]
tkt_5181.log

Comment 34 Abhijeet Kasurde 2016-08-20 17:26 UTC
Created attachment 1192483 [details]
tkt_5689.log

Comment 35 Abhijeet Kasurde 2016-08-21 05:21:50 UTC
Observed BZ1368754 while verifying tkt_5588

Comment 36 Abhijeet Kasurde 2016-08-22 05:07 UTC
Created attachment 1192771 [details]
tkt_5840.log

Comment 37 Abhijeet Kasurde 2016-08-22 08:37 UTC
Created attachment 1192817 [details]
tkt_5867.png

Comment 38 Abhijeet Kasurde 2016-08-22 08:42 UTC
Created attachment 1192828 [details]
tkt_5906.png

Comment 39 Abhijeet Kasurde 2016-08-22 08:46 UTC
Created attachment 1192837 [details]
tkt_5967.png

Comment 40 Abhijeet Kasurde 2016-08-22 09:00 UTC
Created attachment 1192839 [details]
tkt_4987.log

Comment 41 Abhijeet Kasurde 2016-08-22 09:09 UTC
Created attachment 1192857 [details]
tkt_5411.log

Comment 42 Abhijeet Kasurde 2016-08-22 09:34 UTC
Created attachment 1192864 [details]
tkt_5588.log

Comment 43 Abhijeet Kasurde 2016-08-22 09:35:31 UTC
Verified using IPA version ::

ipa-server-4.4.0-8.el7.x86_64

Marking RFE BZ as verified based on above log files.

Comment 45 errata-xmlrpc 2016-11-04 05:49:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.