Bug 1298936 - redhat-lsb-desktop requires qt3 and LSB 5.0 was released June 3, 2015.
redhat-lsb-desktop requires qt3 and LSB 5.0 was released June 3, 2015.
Status: ASSIGNED
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Nykrýn
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 07:50 EST by Sergio Monteiro Basto
Modified: 2017-08-22 06:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Monteiro Basto 2016-01-15 07:50:25 EST
Description of problem:
I want remove qt3 [1] , but removes redhat-lsb-desktop which removes google-chrome-beta 
digging 
http://refspecs.linux-foundation.org/lsb.shtml

and looks like only qt4 is required 


Additional info:

This is not urgent , but just for the JFTR

dnf repoquery --whatrequires qt3 | grep -v ^qt3-

PyQt-0:3.18.1-31.fc23.x86_64
sim-0:0.9.5-0.42.20091129svn3078rev.fc23.i686
sim-0:0.9.5-0.42.20091129svn3078rev.fc23.x86_64

dnf repoquery --whatrequires PyQt | grep -v ^PyQt-

albumart-0:1.6.6-3.fc23.noarch
kodos-0:2.4.9-17.fc23.noarch
kphotobymail-0:0.4.1-16.fc23.noarch
pipviewer-0:0.3.9-17.fc23.noarch


kodos crash at start-up ... 

[1] 
dnf remove qt3
Comment 1 Ondrej Vasik 2016-01-15 12:56:14 EST
Thanks for report, you are right, I should find some time and adjust redhat-lsb to 5.0 specifications. You are right qt3 is no longer required by 5.0 specification.
Comment 2 Neal Gompa 2016-10-30 06:39:20 EDT
Any update on this? It'd be nice if redhat-lsb was LSB 5.0 compliant.

Note You need to log in before you can comment on or make changes to this bug.