Bug 1298968 - Unable to create service dialog for element type dynamic drop down list
Unable to create service dialog for element type dynamic drop down list
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.5.2
Assigned To: eclarizi
Taras Lehinevych
: ZStream
Depends On: 1271104
Blocks: 1235259 1236522 1240309
  Show dependency treegraph
 
Reported: 2016-01-15 09:44 EST by John Prause
Modified: 2016-02-10 10:35 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update resolves an issue that prevented users from creating service dialogs for dynamic drop-down list element types by making it possible to save a DialogFieldDropDownList without values when it is dynamic.
Story Points: ---
Clone Of: 1271104
Environment:
Last Closed: 2016-02-10 10:35:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drop_down_list (59.65 KB, image/png)
2016-01-25 05:10 EST, Taras Lehinevych
no flags Details

  None (edit)
Comment 3 Taras Lehinevych 2016-01-25 05:10 EST
Created attachment 1117897 [details]
drop_down_list
Comment 4 Taras Lehinevych 2016-01-25 05:12:39 EST
Failed verification. 

When you adding the drop down list and Dynamic box is unchecked you will get "Dropdown elements require some entries" error flash message. Please check attachment.
Comment 6 eclarizi 2016-01-25 11:31:47 EST
Um, isn't that intended behavior? If you do not have the dynamic box checked, you need to give it some values, otherwise the drop down will be blank. The original problem was that when the dynamic box was checked, it was still saying that you needed to provide values which did not make sense since it was assumed the values would be coming from the automate method.
Comment 7 Taras Lehinevych 2016-01-25 11:49:02 EST
Thank you for response.
My apologies, you are right. I'll change the status.

Verified fixed in version 5.5.2.2
Comment 8 errata-xmlrpc 2016-02-10 10:35:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.