Bug 1271104 - Unable to create service dialog for element type dynamic drop down list
Unable to create service dialog for element type dynamic drop down list
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.6.0
Assigned To: eclarizi
Aziza Karol
dialog
:
: 1283285 (view as bug list)
Depends On:
Blocks: 1235259 1236522 1240309 1298968
  Show dependency treegraph
 
Reported: 2015-10-13 03:44 EDT by Aziza Karol
Modified: 2016-06-29 11:00 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298968 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:00:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snpshot (69.43 KB, image/png)
2015-10-13 03:44 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-10-13 03:44:24 EDT
Created attachment 1082291 [details]
snpshot

Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.5-beta1.1.20151007163855_ed40d96

How reproducible:
100%

Steps to Reproduce:
1.Navigate to Automate->customization->service dialogs
2.create  a service dialog for element type dynamic drop down list. see attached screenshot
3.

Actual results:
"Dropdown elements require some entries" flash message is displayed.

Expected results:
dynamic dropdown should not require any entries. 

Additional info:
Comment 3 CFME Bot 2015-11-23 19:20:16 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d2a847621eb724e093916fe05c594ad0cf96c2e9

commit d2a847621eb724e093916fe05c594ad0cf96c2e9
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Mon Nov 23 10:42:42 2015 -0800
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Mon Nov 23 10:43:32 2015 -0800

    Allow saving DialogFieldDropDownList without values when it is dynamic
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1271104

 .../miq_ae_customization_controller/dialogs.rb            |  6 +++++-
 .../miq_ae_customization_controller/dialogs_spec.rb       | 15 +++++++++++++++
 2 files changed, 20 insertions(+), 1 deletion(-)
Comment 4 Greg McCullough 2015-11-24 10:53:08 EST
*** Bug 1283285 has been marked as a duplicate of this bug. ***
Comment 6 CFME Bot 2015-12-08 18:51:37 EST
New commit detected on cloudforms/cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f97f15a06b1ba018cd729ec45afa966494cfd701

commit f97f15a06b1ba018cd729ec45afa966494cfd701
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Mon Nov 23 10:42:42 2015 -0800
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Tue Dec 8 09:05:19 2015 -0800

    Allow saving DialogFieldDropDownList without values when it is dynamic
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1271104

 .../miq_ae_customization_controller/dialogs.rb            |  6 +++++-
 .../miq_ae_customization_controller/dialogs_spec.rb       | 15 +++++++++++++++
 2 files changed, 20 insertions(+), 1 deletion(-)
Comment 7 Aziza Karol 2016-04-25 07:28:38 EDT
Able to create service dialog for element type dynamic drop down list.

Verified:5.6.0.4-beta2.3.20160421172650_719e256
Comment 9 errata-xmlrpc 2016-06-29 11:00:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.