Bug 1298986 - Retired vm could be powered on again on openstack cloud provider
Retired vm could be powered on again on openstack cloud provider
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 10:53 EST by Taras Lehinevych
Modified: 2016-08-02 21:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the current version of CloudForms Management Engine, it is not usually possible to run a virtual machine after it has been retired. But, the OpenStack provider still allows a retired virtual machine to be powered on from the OpenStack console. This will result in CloudForms Management Engine reporting the virtual machine to be powered on while retired. In this case, retiring the virtual machine has to be enforced by the CloudForms Management Engine administrator. For example: - Change the State Machine workflow and define the end state of the retired virtual machine to be deleted or removed from provider inventory instead of being stopped or suspended. - Write a Control Policy that watches the provider for virtual machine Start Events and shut down the virtual machine if it has been retired.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 07:02:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openstack (147.11 KB, image/png)
2016-01-15 10:53 EST, Taras Lehinevych
no flags Details
evm.log (10.75 MB, text/plain)
2016-01-15 10:56 EST, Taras Lehinevych
no flags Details
automation.log (485.16 KB, text/plain)
2016-01-15 10:56 EST, Taras Lehinevych
no flags Details

  None (edit)
Description Taras Lehinevych 2016-01-15 10:53:47 EST
Created attachment 1115183 [details]
openstack

Description of problem:
The retired vm on openstack cloud provider could be running again. According to the definition CFME will not allow a retired VM to start/power on, however you can do it now.
Please take a look at screenshot, the power state on appear after resuming the vm and cfme won't shut/power off this vm. 
Also, I'll attach emv and automation log files.

Version-Release number of selected component (if applicable):
5.5.2.0

How reproducible:
Always

Steps to Reproduce:
1. Set up OpenStack cloud provider
2. Open any virtual machine
3. Press Lifecycle -> Retire this VM
4. Wait a little bit and check the status of vm is Retired and power state suspend. 
5. Go to openstack and resume this vm
6. Wait a little bit again and check the status of vm

Actual results:
The status of vm is Retired but power state is on. CFME allow to start/power on retired vm

Expected results:
The power state of vm should be off, CFME shoul shutdown/stop the vm

Additional info:
Also please pay attention that now the retired vm has suspend power state but maybe it will be better to terminate (not suspend) vm during retirement, in this case the customer won't be allow to start vm again.

Moreover on the screenshot you can see the time of change power state, what can be useful during log analysis.

Appliance info:
IP is 10.16.5.163
The vm name is singleheat-server-y7aisp7ki4rs
Comment 1 Taras Lehinevych 2016-01-15 10:56 EST
Created attachment 1115184 [details]
evm.log
Comment 2 Taras Lehinevych 2016-01-15 10:56 EST
Created attachment 1115185 [details]
automation.log
Comment 5 John Hardy 2016-01-21 10:39:01 EST
We want close as NOT A BUG, because;

1. The statemachine workflow that runs retirement is their for the user to decide what state the VM ends up in, choices are infinite but example would be;

a) Delete from disk
b) remove from provider inventory
c) just leave on provider, but stopped or suspended.

Basically the end result is your choice.

If you wish to stop a user starting a VM using external tooling then our course of action would be to write a control policy that watches the provider for vm start events and stop them if the vm is marked as retired in CF.

this again would be your choice.

thanks
Comment 6 Taras Lehinevych 2016-01-22 07:02:01 EST
John, 

Thank you for provided information. 
I'm closing this bug.
Comment 7 Shikha 2016-02-10 01:21:51 EST
Providing doc-text since it's a known issue. Also including the doc-text in the CloudForms Management Engine 4.0 Release Notes under Known Issues, as requested in Bug 1301560. 

Regards,
Shikha

Note You need to log in before you can comment on or make changes to this bug.