Bug 1299049 - Network interface profiles disappeared after upgrading to 3.6.1
Network interface profiles disappeared after upgrading to 3.6.1
Status: CLOSED DUPLICATE of bug 1293294
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
Unspecified Linux
unspecified Severity high (vote)
: ovirt-3.6.2
: ---
Assigned To: Tomas Jelinek
Pavel Stehlik
Depends On:
  Show dependency treegraph
Reported: 2016-01-15 14:48 EST by nicolas
Modified: 2016-01-20 07:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-20 07:18:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?

Attachments (Terms of Use)
Screenshot of the VNic window (55.73 KB, image/png)
2016-01-15 14:48 EST, nicolas
no flags Details

  None (edit)
Description nicolas 2016-01-15 14:48:26 EST
Created attachment 1115268 [details]
Screenshot of the VNic window

Description of problem:

We recently upgraded from 3.5.3 to 3.6.1. Everything went fairly smooth, however, today we realized we're facing some issues.

Users cannot add network interfaces on the User Portal to their VMs. It seems that when they click on "New", the "Profile" checkbox is empty so they cannot choose any value.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:

The issue throws two uncaught exception popups.

First error

1. Login to the User Portal
2. On the Extended view, click on any VM
3. In the Network Interfaces tab, click on New
4. A popup with an Uncaught exception is shown: (TypeError) __gwt$exception: <skipped>: NMk(...) is null
5. Checkbox to the Profile field is always empty, thus no interface might be added.

The exception data contains this:

Fri Jan 15 19:19:15 GMT+000 2016 
SEVERE: Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: NMk(...) is null
	at Unknown.POm(Unknown Source)
	at Unknown.ZFk(Unknown Source)
	at Unknown.aGk(Unknown Source)
	at Unknown.SJk(Unknown Source)
	at Unknown.VJk(Unknown Source)
	at Unknown.yIk(Unknown Source)
	at Unknown.BIk(Unknown Source)
	at Unknown.bTc(Unknown Source)
	at Unknown.B6h(Unknown Source)
	at Unknown.VS(Unknown Source)
	at Unknown.mT(Unknown Source)
	at Unknown.jAd/c.onreadystatechange<(Unknown Source)
	at Unknown.Yp(Unknown Source)
	at Unknown.aq(Unknown Source)
	at Unknown._p/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)

From the 67DA206BA450D4E3DB6679D8DE8FF6E0.symbolMap file: 


Second error

Exactly same steps as above, but exception is:

SEVERE: Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'r' of null
	at Unknown.MOm(<anonymous>@534837)
	at Unknown.WFk(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@49)
	at Unknown.ZFk(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@364)
	at Unknown.PJk(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@40)
	at Unknown.SJk(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@24798)
	at Unknown.vIk(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@25)
	at Unknown.yIk(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@23049)
	at Unknown.YSc(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@14821)
	at Unknown.y6h(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@2013)
	at Unknown.lT(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@137)
	at Unknown.ET(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@3663)
	at Unknown.<anonymous>(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@65)
	at Unknown.Zp(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@29)
	at Unknown.bq(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@57)
	at Unknown.<anonymous>(https://fqdn/ovirt-engine/userportal/6610290E43BFC953D54ABE4A12EE2839.cache.html@54)

From the 6610290E43BFC953D54ABE4A12EE2839.symbolMap file:


Additional info:

It's worth mentioning that we only upgraded the manager, not yet the

It's also worth mentioning that I can add interfaces from the admin
portal. It's only the user portal where this happens.

Seems not related to permissions, as I granted the user the VnicProfileUser and even NetworkAdmin permissions. Same result.
Comment 1 Dan Kenigsberg 2016-01-17 15:33:04 EST
I suspect you are seeing Bug 1293294.

Would you try ovirt-3.6.2 beta http://www.ovirt.org/OVirt_3.6.2_Release_Notes , which should fix it?

Does the management network (ovirtmgmt most probably) has vnic profiles related to it?
Comment 2 nicolas 2016-01-18 06:22:49 EST
I confirm that upgrading to ovirt-3.6.2beta fixes this issue, so I guess it is indeed a duplicate of #1293294.

In our case, the management network didn't have any VNic profiles related to it.

Comment 3 Dan Kenigsberg 2016-01-20 07:18:09 EST

*** This bug has been marked as a duplicate of bug 1293294 ***

Note You need to log in before you can comment on or make changes to this bug.