Bug 1293294 - cannot add NIC using user portal (but it works in Admin portal)
cannot add NIC using user portal (but it works in Admin portal)
Status: CLOSED DUPLICATE of bug 1286984
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.6.1
Unspecified Unspecified
high Severity high
: ovirt-3.6.2
: ---
Assigned To: Alona Kaplan
Pavel Stehlik
network
: Regression, Reopened
: 1299049 (view as bug list)
Depends On:
Blocks: 1213937
  Show dependency treegraph
 
Reported: 2015-12-21 05:57 EST by Petr Spacek
Modified: 2016-02-10 14:15 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 13:13:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast of creating a new VM from template which has NIC specified (973.06 KB, application/octet-stream)
2016-01-04 09:00 EST, Petr Spacek
no flags Details

  None (edit)
Description Petr Spacek 2015-12-21 05:57:54 EST
Description of problem:
After upgrade to RHEV-M 3.6.1, the "New VM" dialog in User Portal does not offer any NIC profile for selection. Also, when creating a new VM from a template which has NIC attached, the NIC is not present in the resulting VM.

The "Network interfaces" tab on a existing VM has the "New" button is grayed out.

When I attempt to edit an existing template, I can click to "New" button on Network interfaces tab but the drop-down list "Profiles" is empty and I'm unable to create any NIC.

Version-Release number of selected component (if applicable):
3.6.1-0.2.el6

How reproducible:
100 %

Steps to Reproduce:
1. Using User portal, create a new VM from a template which has NIC attached.

Actual results:
The VM is created without a NIC.

Expected results:
VM should be created with NIC as prescribed by the template.

Additional information:
The drop-down list of NIC profiles in "New VM" dialog is empty.

I'm able to create the VM from template by using Admin portal, so it seems to be a problem in User portal. Please note that I'm using the same credentials for user & admin portals so permissions are likely not an issue.
Comment 2 Dan Kenigsberg 2015-12-23 04:44:01 EST
Smells like bug 1268298, but would you add engine.log?
Comment 3 Alona Kaplan 2016-01-03 10:06:08 EST
Hi Petr,

You are describing here 3 different bugs-
1. The "New VM" dialog in User Portal does not offer any NIC profile for selection.
2. When creating a new VM from a template which has NIC attached, the NIC is not present in the resulting VM.
3. The "Network interfaces" tab on a existing VM has the "New" button is grayed out.

My answers-
1. I managed to reproduce it in a certain scenario.
In case there are no templates in the dc, only the blank template should be presented in the templates drop down (in the new vm dialog).
The bug is - the blank template is not presented, so there are no templates in the templates drop down. Since the vnic profiles depend on the selected template, the lack of the template causes no vnic profiles to appear.

Pert, is this what happened to you? Or you cannot see the vnic profiles even if there is a selected template?

2, 3- are the second two bugs happen to you only in the user portal or also in the webadmin. I couldn't reproduce it.

Can you please add an engine.log and screenshots of the described bugs.
Comment 4 Petr Spacek 2016-01-04 03:54:34 EST
I do not have access to logs, hopefully dprezhev@redhat.com will be able to dig out what you need.

I've just reproduced the issue in the environment. Approximate timestamps follow to ease log digging:

~ 2016-01-04T09:23:32+0100 clicked to 'New VM'

When opening the New VM dialog, following exception was thrown:
09:23:40.755 Mon Jan 04 09:23:40 GMT+100 2016
SEVERE: Uncaught exception: com.google.gwt.core.client.JavaScriptException:
(TypeError)
 __gwt$exception: <skipped>: gMk(...) is null
	at Unknown.eOm(Unknown Source)
	at Unknown.sFk(Unknown Source)
	at Unknown.vFk(Unknown Source)
	at Unknown.lJk(Unknown Source)
	at Unknown.oJk(Unknown Source)
	at Unknown.jIk(Unknown Source)
	at Unknown.mIk(Unknown Source)
	at Unknown.ASc(Unknown Source)
	at Unknown.W5h(Unknown Source)
	at Unknown.VS(Unknown Source)
	at Unknown.mT(Unknown Source)
	at Unknown.Izd/c.onreadystatechange<(Unknown Source)
	at Unknown.Yp(Unknown Source)
	at Unknown.aq(Unknown Source)
	at Unknown._p/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
1 95524F85561A45E41FEEEB6F76F1BC69.cache.html:6298:7804
PNc() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:6298
YOc() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:5917
XOc() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:5301
lPc() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:2780
Gei() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:6334
gq() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:4946
aq() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:5697
_p/<() 95524F85561A45E41FEEEB6F76F1BC69.cache.html:5532

Web console contained this line right after the exception:
POST XHR
https://rhevm.abc.idm.lab.eng.brq.redhat.com/ovirt-engine/userportal/GenericApiGWTService
[HTTP/1.1 401 Authorization Required 252ms]


Then I created VM 'pspacek-nic-reproducer' from template
ipa-Fedora-23-x86_64-developer-brq. I've clicked to Ok in New VM dialog at ~
2016-01-04T09:27:42+0100.

The VM was created without any NIC (but the template does contain 1 NIC).
Comment 6 Petr Spacek 2016-01-04 09:00 EST
Created attachment 1111488 [details]
screencast of creating a new VM from template which has NIC specified
Comment 7 Alona Kaplan 2016-01-04 12:57:15 EST
Seems like duplicate of https://bugzilla.redhat.com/1286984
Comment 8 Alona Kaplan 2016-01-04 13:13:27 EST

*** This bug has been marked as a duplicate of bug 1286984 ***
Comment 9 Dan Kenigsberg 2016-01-20 07:18:09 EST
*** Bug 1299049 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.