Bug 1299089 - Clicking on resources in UserPortal throws Uncaught Exception
Clicking on resources in UserPortal throws Uncaught Exception
Status: CLOSED DUPLICATE of bug 1291156
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.1.3
x86_64 Linux
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 17:31 EST by nicolas
Modified: 2016-01-16 09:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-16 09:19:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description nicolas 2016-01-15 17:31:14 EST
Description of problem:

When clicking on the 'Resources' left menu item inside UserPortal, an uncaught exception is thrown N times (until Resources is left).

Version-Release number of selected component (if applicable):
3.6.1.3

How reproducible:
Always

Steps to Reproduce:
1. Log in to the UserPortal
2. Click on the Extended view
3. Click on Resources on the left side menu

Actual results:

This uncaught exception is thrown:

Fri Jan 15 22:23:01 GMT+000 2016 
SEVERE: Uncaught exception: java.lang.IllegalStateException: Please do not call this overload of render(). Use the overload with an id.
	at Unknown.qo(Unknown Source)
	at Unknown.po(Unknown Source)
	at Unknown.vo(Unknown Source)
	at Unknown.xo(Unknown Source)
	at Unknown.aKd(Unknown Source)
	at Unknown.Kgj(Unknown Source)
	at Unknown.v8n(Unknown Source)
	at Unknown.Ogj(Unknown Source)
	at Unknown.Y_c(Unknown Source)
	at Unknown.MZc(Unknown Source)
	at Unknown.v0c(Unknown Source)
	at Unknown.GZc(Unknown Source)
	at Unknown.nYc(Unknown Source)
	at Unknown.YYc(Unknown Source)
	at Unknown.WZc(Unknown Source)
	at Unknown.O0c(Unknown Source)
	at Unknown.g1c(Unknown Source)
	at Unknown.Jq(Unknown Source)
	at Unknown.zq(Unknown Source)
	at Unknown.bq(Unknown Source)
	at Unknown.aq(Unknown Source)
	at Unknown._p/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
 68B29A31C96B6D16F075F2EEE0FC6527.cache.html:6298:7804

Having a look at the 68B29A31C96B6D16F075F2EEE0FC6527.symbolMap, concretly the 'qo' hash:

qo,java.lang.Throwable::fillInStackTrace()Ljava/lang/Throwable;,java.lang.Throwable,fillInStackTrace,com/google/gwt/emul/java/lang/Throwable.java,114,0
Comment 1 Einav Cohen 2016-01-16 09:19:52 EST

*** This bug has been marked as a duplicate of bug 1291156 ***

Note You need to log in before you can comment on or make changes to this bug.