Bug 129911 - Fedora Installation Guide
Fedora Installation Guide
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
: FutureFeature
Depends On:
Blocks: fedora-docs-writing
  Show dependency treegraph
 
Reported: 2004-08-13 21:04 EDT by Karsten Wade
Modified: 2007-04-18 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-13 08:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Draft Beginning Installation chapter for Fedora Installation Guide (17.06 KB, text/xml)
2004-09-26 20:23 EDT, Stuart Ellis
no flags Details
Draft Network Installation Servers Chapter for Fedora Installation Guide (15.58 KB, text/xml)
2004-09-26 20:27 EDT, Stuart Ellis
no flags Details
Draft Upgrading Chapter for Fedora Installation Guide (3.12 KB, text/xml)
2004-09-26 20:30 EDT, Stuart Ellis
no flags Details
Draft "Installation Types" Chapter (2.07 KB, text/xml)
2004-10-03 14:50 EDT, Stuart Ellis
no flags Details
Draft "Network Configuration" Chapter for Installation Guide (4.17 KB, text/plain)
2004-10-03 14:51 EDT, Stuart Ellis
no flags Details
"Default Partition Scheme" Note for Installation Guide (988 bytes, text/xml)
2004-10-03 14:53 EDT, Stuart Ellis
no flags Details
Draft "Network Installation Servers" Chapter for Fedora Installation Guide (17.12 KB, text/xml)
2004-10-14 18:44 EDT, Stuart Ellis
no flags Details
Draft "Firewall Configuration" Chapter for Fedora Installation Guide (3.03 KB, text/xml)
2004-10-14 18:46 EDT, Stuart Ellis
no flags Details
Draft "Language Support" Chapter for Fedora Installation Guide (1.38 KB, text/xml)
2004-10-14 18:47 EDT, Stuart Ellis
no flags Details
Draft "Timezone Configuration" Chapter for Fedora Installation Guide (1.97 KB, text/xml)
2004-10-14 18:48 EDT, Stuart Ellis
no flags Details
Draft "Root Password" Chapter for Fedora Installation Guide (1.73 KB, text/xml)
2004-10-14 18:49 EDT, Stuart Ellis
no flags Details
Draft "Disk Partitioning" chapter for Fedora Installation Guide (finally!) (14.88 KB, text/plain)
2005-04-09 00:03 EDT, Paul W. Frields
no flags Details
New draft "DIsk Partitioning" chapter for FIG (15.73 KB, text/xml)
2005-04-11 13:13 EDT, Paul W. Frields
no flags Details

  None (edit)
Description Karsten Wade 2004-08-13 21:05:00 EDT
Started a discussion on the list about doing an Installation Guide (IG):

http://www.redhat.com/archives/fedora-docs-list/2004-August/msg00129.html

Tammy has a good sounding plan for doing a modular IG:

1. Create a ToC for the mailing list to discuss
2. Create empty files in CVS based on the ToC
3. People can volunteer to:
   - write one or more sections or chapters
   - take screenshots
   - QA and edit

Thinking in terms of multiple-architecture support is a good idea. 
For example, we can use DocBook conditionals that allow you to mark a
<para> as being only included for certain criteria such as
architecture.  For example, if the build for the IBM S390/zSeries
requires some special tricks to get to the first screen of the boot
CD, those tricks are in a <para> marked as "only for zSeries build".
Comment 1 Paul W. Frields 2004-08-27 18:26:35 EDT
As noted on fedora-docs-list, there's currently a ToC in CVS that we
probably can and should work from. I will volunteer to edit parts, as
long as that doesn't stop me from writing other parts. I think we need
as many writers on this one as we can get away with, given the size of
the project (and how much we need it done). I don't have experience
beyond the ix86 arch, but certainly other arches could be dealt with
later as long as we have a strong document to begin with.

I'm getting on the CC list, and I will volunteer right now to handle
disk partitioning -- the setup, automatic, and manual. That's probably
enough to chew for a bit.

I would like to suggest several guidelines for screenshots and any
other graphics:

1. PNG format. Is that too obvious?
2. No wider than 500 pixels. If your graphic is larger than that, use
GIMP (Image -> Scale Image) or mogrify to scale the image to no wider
than 500 pixels.
3. Graphics should be included as <figure> I think.

Can someone else more knowledgeable in guide creation (*cough* Tammy
*cough* Karsten *cough*) add to this list?
Comment 2 Stuart Ellis 2004-09-07 15:32:27 EDT
(Added myself to the CC list) 
Comment 3 Stuart Ellis 2004-09-26 20:23:26 EDT
Created attachment 104339 [details]
Draft Beginning Installation chapter for Fedora Installation Guide
Comment 4 Stuart Ellis 2004-09-26 20:27:50 EDT
Created attachment 104340 [details]
Draft Network Installation Servers Chapter for Fedora Installation Guide

This is not on the original ToC, but it seemed reasonable since PXE boot and
network install methods are part of the IG.
Comment 5 Stuart Ellis 2004-09-26 20:30:06 EDT
Created attachment 104341 [details]
Draft Upgrading Chapter for Fedora Installation Guide
Comment 6 Stuart Ellis 2004-10-03 14:50:05 EDT
Created attachment 104684 [details]
Draft "Installation Types" Chapter
Comment 7 Stuart Ellis 2004-10-03 14:51:06 EDT
Created attachment 104685 [details]
Draft "Network Configuration" Chapter for Installation Guide
Comment 8 Stuart Ellis 2004-10-03 14:53:59 EDT
Created attachment 104686 [details]
"Default Partition Scheme" Note for Installation Guide

Not a chapter, just a piece that someone can recycle if it's useful.
Comment 9 Stuart Ellis 2004-10-14 18:44:53 EDT
Created attachment 105247 [details]
Draft "Network Installation Servers" Chapter for Fedora Installation Guide

Updated for FC3t3.
Comment 10 Stuart Ellis 2004-10-14 18:46:11 EDT
Created attachment 105248 [details]
Draft "Firewall Configuration" Chapter for Fedora Installation Guide
Comment 11 Stuart Ellis 2004-10-14 18:47:23 EDT
Created attachment 105249 [details]
Draft "Language Support" Chapter for Fedora Installation Guide
Comment 12 Stuart Ellis 2004-10-14 18:48:32 EDT
Created attachment 105250 [details]
Draft "Timezone Configuration" Chapter for Fedora Installation Guide
Comment 13 Stuart Ellis 2004-10-14 18:49:22 EDT
Created attachment 105251 [details]
Draft "Root Password" Chapter for Fedora Installation Guide
Comment 14 Tammy Fox 2004-10-22 16:18:44 EDT
I'm changing this bug to block the docs in progress bug since Stuart
has made great progress on this. Great work Stuart!
Comment 15 Paul W. Frields 2005-04-09 00:03:33 EDT
Created attachment 112904 [details]
Draft "Disk Partitioning" chapter for Fedora Installation Guide (finally!)
Comment 16 Paul W. Frields 2005-04-11 13:13:50 EDT
Created attachment 112956 [details]
New draft "DIsk Partitioning" chapter for FIG

This new Disk Partitioning chapter supersedes the old one.  It now moves in a
more linear fashion.  First it gives the reader advice on whether to choose
automatic or manual partitions.  If the reader chooses manual, the chapter now
provides a small section about partition setup, to be read if necessary, before
making manual choices with Disk Druid.	This chapter should flow more like a
tutorial now.
Comment 17 Karsten Wade 2005-04-27 17:50:26 EDT
Suggestion from IRC to include the approximate size of an Everything installation.
Comment 18 Karsten Wade 2005-04-27 17:57:22 EDT
Which, uh, is in the release notes, but is still a nice thing:

<Evenios> http://fedora.redhat.com/docs/release-notes/fc3/x86/
<Evenios> fedora core 3 release notes (non 64-bit)
<Evenios>  Custom Installation (Everything): 6.9GB

So, we can include it if it's not a hassle.
Comment 19 Stuart Ellis 2005-04-27 18:27:26 EDT
I'll put it in.  6.9 Gb is worth a comment :)
Comment 20 Paul W. Frields 2005-04-30 14:19:42 EDT
Committed Stuart's 0.6.2 release to docs CVS.
Comment 21 Tommy Reynolds 2005-05-16 17:33:39 EDT
I think we need to add an admonition to the Language Selection section about
making sure that *every* needed language is added at install time because adding
it later is impossible.  Below is a patch:

Index: fedora-install-guide-packageselection-en.xml
===================================================================
RCS file: /cvs/docs/install-guide/fedora-install-guide-packageselection-en.xml,v
retrieving revision 1.7
diff -u -p -r1.7 fedora-install-guide-packageselection-en.xml
--- fedora-install-guide-packageselection-en.xml	15 May 2005 16:02:49 -0000	1.7
+++ fedora-install-guide-packageselection-en.xml	16 May 2005 21:29:20 -0000
@@ -154,6 +153,14 @@
       group.
     </para>
 
+    <warning>
+      <title>Language Selection Is Permanent</title>
+      <para>
+        Be sure to include every language that may be needed for your system.
+        Adding additional languages after the installation is completed is
neither supported nor recommended.
+      </para>
+    </warning>
+
   </section>
 
 


Cheers
Comment 22 Stuart Ellis 2005-05-16 20:03:53 EDT
Thanks - I've now added this.
Comment 23 Paul W. Frields 2005-06-24 13:19:03 EDT
To help us keep a handle on work, I've set up a tracker bug (#161575).  I would
recommend this bug be CLOSED as CURRENTRELEASE since the IG has actually been
issued at this point.  The following section is here for the information of new
users who may not be familiar with Bugzilla.

= = = = =
Any further RFE's or other suggestions should be entered as NEW bugs, and set to
block bug #161575 ("ig-traqr").  Visit the following URL to create a new bug:

http://tinyurl.com/9t266

After you commit your new bug, skip to the bottom of the report and find the
field labeled "Bug <NUMBER> blocks:" and enter either "ig-traqr" or the
Installation Guide tracker bug number (#161575) in that field.
Comment 24 Paul W. Frields 2005-07-13 08:04:52 EDT
This notice is probably unnecessary, since this bug will be closed, but just in
case someone is trolling for old bugs:

Because Fedora Documentation now has its own product and components, bug entries
for the Install Guide will be entered slightly differently.  Ignore comment #23
above and use this TinyURL instead:

http://tinyurl.com/8wuz4

The "ig-traqr" bug is automatically blocked.

Note You need to log in before you can comment on or make changes to this bug.