Bug 1299200 - Disable cloud-init service after appliance deployment
Summary: Disable cloud-init service after appliance deployment
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 1.3.2.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-3.6.3
: 1.3.3.4
Assignee: Simone Tiraboschi
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-1 1305885
TreeView+ depends on / blocked
 
Reported: 2016-01-17 10:17 UTC by Artyom
Modified: 2016-03-11 07:23 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
cloud-init services are now disabled on the engine-appliance after the initial deployment in order to speed up subsequent boots.
Clone Of:
Environment:
Last Closed: 2016-03-11 07:23:34 UTC
oVirt Team: Integration
rule-engine: ovirt-3.6.z+
rule-engine: exception+
ylavi: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
screenshot (19.77 KB, image/png)
2016-02-17 13:31 UTC, Artyom
no flags Details
he-setup-log (411.56 KB, text/plain)
2016-02-17 13:32 UTC, Artyom
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 52453 master MERGED cloud-init: disable cloud-init services after appliance deployment 2020-02-13 08:14:29 UTC
oVirt gerrit 52963 ovirt-hosted-engine-setup-1.3 MERGED cloud-init: disable cloud-init services after appliance deployment 2020-02-13 08:14:29 UTC
oVirt gerrit 53787 master MERGED cloud-init: disabling cloud-init services also on el6 2020-02-13 08:14:29 UTC
oVirt gerrit 53874 ovirt-hosted-engine-setup-1.3 MERGED cloud-init: disabling cloud-init services also on el6 2020-02-13 08:14:29 UTC

Description Artyom 2016-01-17 10:17:45 UTC
Description of problem:
I believe we need to disable cloud-init service after we finish deployment via appliance, because it take additional 2 minutes on boot of OS(cloud-init trying to find configuration and failed after timeout)

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine via appliance
2. Wait for start of HE vm after deployment
3.

Actual results:
Start of vm takes too much time(because cloud-init timeout)

Expected results:
Start of vm not take too much time

Additional info:

Comment 1 Yaniv Kaul 2016-01-17 10:31:14 UTC
I believe running:
systemctl mask cloud-final.service
and
systemctl mask cloud-config.service

Should do the trick.

Is this a bug or a RFE?

Comment 2 Artyom 2016-01-17 11:53:54 UTC
I think it more like RFE, but if we want to reduce down time of the engine, it necessary to disable cloud-init service on start up.

Comment 3 Yaniv Kaul 2016-01-17 11:59:47 UTC
(In reply to Artyom from comment #2)
> I think it more like RFE, but if we want to reduce down time of the engine,
> it necessary to disable cloud-init service on start up.

I fully agree - I think it's an important one to implement (and hopefully as easy as I've described above).

(BTW, perhaps there's a way to shorten the timeout for cloud-init - see bug 1039388 )

Comment 4 Artyom 2016-01-17 13:54:41 UTC
Yes, looks like fix for the bug 1039388, can help us, but I also see, that bug exist from 6.5 and it still has status new(

Comment 5 Simone Tiraboschi 2016-01-19 16:04:20 UTC
(In reply to Yaniv Kaul from comment #1)
> I believe running:
> systemctl mask cloud-final.service
> and
> systemctl mask cloud-config.service
> 
> Should do the trick.

Doing it via cloud-init itself is pretty easy but of-course it will be effective only if the user will decide to use cloud-init.
If not it will be up to him to stop it since it's enabled by default on the appliance.

Comment 6 Sandro Bonazzola 2016-01-19 21:01:33 UTC
Impacting downtime and boot performances, I think this should be addressed in 3.6.

Comment 7 Artyom 2016-02-17 13:31:04 UTC
Created attachment 1127945 [details]
screenshot

Checked on ovirt-hosted-engine-setup-1.3.3.3-1.el7ev.noarch
I can see that cloud-init still enabled on startup(see screenshot).
I do not really sure that mask help to avoid cloud-init startup, why just do not send:
systemctl disable cloud-init

Comment 8 Red Hat Bugzilla Rules Engine 2016-02-17 13:31:26 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 9 Artyom 2016-02-17 13:32:24 UTC
Created attachment 1127946 [details]
he-setup-log

Comment 10 Simone Tiraboschi 2016-02-22 10:29:40 UTC
(In reply to Artyom from comment #7)
> Created attachment 1127945 [details]
> screenshot
> 
> Checked on ovirt-hosted-engine-setup-1.3.3.3-1.el7ev.noarch
> I can see that cloud-init still enabled on startup(see screenshot).
> I do not really sure that mask help to avoid cloud-init startup, why just do
> not send:
> systemctl disable cloud-init

mask is stronger than disable; was your appliance el7 or el6 based?

Comment 11 Artyom 2016-02-22 11:28:03 UTC
I believe you right.
OS on appliance RHEL6.7.

Comment 14 Artyom 2016-02-25 11:54:26 UTC
Verified on ovirt-hosted-engine-setup-1.3.3.4-1.el7ev.noarch


Note You need to log in before you can comment on or make changes to this bug.