Bug 1299265 - nova-consoleauth fails to parse the ipv6 address in nova.conf/memcached_servers
Summary: nova-consoleauth fails to parse the ipv6 address in nova.conf/memcached_servers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Marios Andreou
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On: 1299510
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-18 00:00 UTC by Marius Cornea
Modified: 2016-04-18 07:13 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-106.el7ost
Doc Type: Bug Fix
Doc Text:
'nova-consoleauth' failed to start due to how it parsed IPv6 addresses for 'memcached_servers' in 'nova.conf'. This fix corrects for the director's Heat template collection parses 'memcached_servers'. The 'nova-consoleauth' service now starts successfully.
Clone Of:
: 1299510 (view as bug list)
Environment:
Last Closed: 2016-02-18 16:50:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1536103 None None None 2016-01-20 11:03:08 UTC
OpenStack gerrit 270110 None None None 2016-01-20 11:02:09 UTC
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Marius Cornea 2016-01-18 00:00:55 UTC
Description of problem:
nova-consoleauth is unable to start because it fails to parse the ipv6 address in nova.conf/memcached_servers:

CRITICAL nova [-] ValueError: Unable to parse connection string: "fd00:fd00:fd00:2000:f816:3eff:febb:6f34:11211"

Version-Release number of selected component (if applicable):
openstack-nova-novncproxy-2015.1.2-15.el7ost.noarch
openstack-nova-common-2015.1.2-15.el7ost.noarch
openstack-nova-cert-2015.1.2-15.el7ost.noarch
openstack-nova-scheduler-2015.1.2-15.el7ost.noarch
openstack-nova-compute-2015.1.2-15.el7ost.noarch
openstack-nova-console-2015.1.2-15.el7ost.noarch
openstack-nova-api-2015.1.2-15.el7ost.noarch
openstack-nova-conductor-2015.1.2-15.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy ipv6 enabled overcloud
2. SSH to the controller node
3. systemctl status openstack-nova-consoleauth.service

Actual results:
[root@overcloud-controller-0 nova]# systemctl status openstack-nova-consoleauth.service
● openstack-nova-consoleauth.service - OpenStack Nova VNC console auth Server
   Loaded: loaded (/usr/lib/systemd/system/openstack-nova-consoleauth.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2016-01-17 18:31:57 EST; 27min ago

CRITICAL nova [-] ValueError: Unable to parse connection string: "fd00:fd00:fd00:2000:f816:3eff:febb:6f34:11211"


Expected results:
nova-consoleauth starts.

Comment 1 Emilien Macchi 2016-01-18 00:27:37 UTC
what if you put brackets in config file?
Like:

memcached_servers = ['[fd00:fd00:fd00:2000:f816:3eff:febb:6f34]:11211']

(memcached_servers is an array).
If it works, we might want to patch THT.

Comment 2 Marius Cornea 2016-01-18 08:33:00 UTC
I got the same result:

memcached_servers=['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']


ValueError: Unable to parse connection string: "['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']"

Comment 3 Marios Andreou 2016-01-18 10:49:02 UTC
(In reply to Marius Cornea from comment #2)
> I got the same result:
> 
> memcached_servers=['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']
> 
> 
> ValueError: Unable to parse connection string:
> "['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']"


on my v4 env, the memcached_servers in nova.conf is like:

memcached_servers=172.16.2.8:11211,172.16.2.6:11211,172.16.2.9:11211

so i don't think we need the external []... so:

memcached_servers=[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211,[fd00:fd00:fd00:2000:f816:3eff:feec:864a]:11211

can we try it. at least i can't find any reports of upstream bug at https://bugs.launchpad.net/nova wrt memcached/consoleauth v6... not to say there isn't one.

Comment 4 Marios Andreou 2016-01-18 11:02:38 UTC
12:58 < mcornea> marios: it doesn't seem to work: ValueError: Unable to parse connection string: "[fd00:fd00:fd00:2000:f816:3eff:fea4:38ba]:11211"

Comment 5 Marius Cornea 2016-01-18 11:19:14 UTC
It looks that this got fixed by:
https://bugs.launchpad.net/python-memcached/+bug/1028412

but the installed version(python-memcached-1.48-4.el7.noarch) doesn't contain the patch.

I got it successfully started with python-memcached-1.53-3.el7ost.noarch and the following declaration in nova.conf:
memcached_servers=inet6:[fd00:fd00:fd00:2000:f816:3eff:fea4:38ba]:11211

Comment 7 Marius Cornea 2016-01-19 11:12:02 UTC
openstack-tripleo-heat-templates-0.8.6-106.el7ost.noarch

[root@overcloud-controller-0 ~]#  systemctl status openstack-nova-consoleauth.service
● openstack-nova-consoleauth.service - Cluster Controlled openstack-nova-consoleauth
   Loaded: loaded (/usr/lib/systemd/system/openstack-nova-consoleauth.service; disabled; vendor preset: disabled)
  Drop-In: /run/systemd/system/openstack-nova-consoleauth.service.d
           └─50-pacemaker.conf
   Active: active (running) since Tue 2016-01-19 05:42:00 EST; 29min ago
 Main PID: 8519 (nova-consoleaut)
   CGroup: /system.slice/openstack-nova-consoleauth.service
           └─8519 /usr/bin/python /usr/bin/nova-consoleauth

Jan 19 05:41:59 overcloud-controller-0.localdomain systemd[1]: Starting Cluster Controlled openstack-nova-consoleauth...
Jan 19 05:42:00 overcloud-controller-0.localdomain systemd[1]: Started Cluster Controlled openstack-nova-consoleauth.

Comment 9 errata-xmlrpc 2016-02-18 16:50:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.