Bug 1299510 - nova-consoleauth fails to parse the ipv6 address in nova.conf/memcached_servers [NEEDINFO]
nova-consoleauth fails to parse the ipv6 address in nova.conf/memcached_servers
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-memcached (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: z4
: 7.0 (Kilo)
Assigned To: RHOS Maint
yeylon@redhat.com
: ZStream
Depends On:
Blocks: 1299265
  Show dependency treegraph
 
Reported: 2016-01-18 09:37 EST by Mike Burns
Modified: 2016-04-18 03:13 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-memcached-1.53-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1299265
Environment:
Last Closed: 2016-02-18 11:10:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ddomingo: needinfo? (rhos-maint)


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2016-01-18 09:37:26 EST
The fix for this bug also requires a new python-memcached.

+++ This bug was initially created as a clone of Bug #1299265 +++

Description of problem:
nova-consoleauth is unable to start because it fails to parse the ipv6 address in nova.conf/memcached_servers:

CRITICAL nova [-] ValueError: Unable to parse connection string: "fd00:fd00:fd00:2000:f816:3eff:febb:6f34:11211"

Version-Release number of selected component (if applicable):
openstack-nova-novncproxy-2015.1.2-15.el7ost.noarch
openstack-nova-common-2015.1.2-15.el7ost.noarch
openstack-nova-cert-2015.1.2-15.el7ost.noarch
openstack-nova-scheduler-2015.1.2-15.el7ost.noarch
openstack-nova-compute-2015.1.2-15.el7ost.noarch
openstack-nova-console-2015.1.2-15.el7ost.noarch
openstack-nova-api-2015.1.2-15.el7ost.noarch
openstack-nova-conductor-2015.1.2-15.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy ipv6 enabled overcloud
2. SSH to the controller node
3. systemctl status openstack-nova-consoleauth.service

Actual results:
[root@overcloud-controller-0 nova]# systemctl status openstack-nova-consoleauth.service
● openstack-nova-consoleauth.service - OpenStack Nova VNC console auth Server
   Loaded: loaded (/usr/lib/systemd/system/openstack-nova-consoleauth.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2016-01-17 18:31:57 EST; 27min ago

CRITICAL nova [-] ValueError: Unable to parse connection string: "fd00:fd00:fd00:2000:f816:3eff:febb:6f34:11211"


Expected results:
nova-consoleauth starts.

--- Additional comment from Emilien Macchi on 2016-01-17 19:27:37 EST ---

what if you put brackets in config file?
Like:

memcached_servers = ['[fd00:fd00:fd00:2000:f816:3eff:febb:6f34]:11211']

(memcached_servers is an array).
If it works, we might want to patch THT.

--- Additional comment from Marius Cornea on 2016-01-18 03:33:00 EST ---

I got the same result:

memcached_servers=['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']


ValueError: Unable to parse connection string: "['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']"

--- Additional comment from marios on 2016-01-18 05:49:02 EST ---

(In reply to Marius Cornea from comment #2)
> I got the same result:
> 
> memcached_servers=['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']
> 
> 
> ValueError: Unable to parse connection string:
> "['[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211']"


on my v4 env, the memcached_servers in nova.conf is like:

memcached_servers=172.16.2.8:11211,172.16.2.6:11211,172.16.2.9:11211

so i don't think we need the external []... so:

memcached_servers=[fd00:fd00:fd00:2000:f816:3eff:feec:863c]:11211,[fd00:fd00:fd00:2000:f816:3eff:feec:864a]:11211

can we try it. at least i can't find any reports of upstream bug at https://bugs.launchpad.net/nova wrt memcached/consoleauth v6... not to say there isn't one.

--- Additional comment from marios on 2016-01-18 06:02:38 EST ---

12:58 < mcornea> marios: it doesn't seem to work: ValueError: Unable to parse connection string: "[fd00:fd00:fd00:2000:f816:3eff:fea4:38ba]:11211"

--- Additional comment from Marius Cornea on 2016-01-18 06:19:14 EST ---

It looks that this got fixed by:
https://bugs.launchpad.net/python-memcached/+bug/1028412

but the installed version(python-memcached-1.48-4.el7.noarch) doesn't contain the patch.

I got it successfully started with python-memcached-1.53-3.el7ost.noarch and the following declaration in nova.conf:
memcached_servers=inet6:[fd00:fd00:fd00:2000:f816:3eff:fea4:38ba]:11211
Comment 2 Marius Cornea 2016-01-19 06:10:29 EST
[root@overcloud-controller-0 ~]# rpm -qa | grep python-memcached
python-memcached-1.53-3.el7ost.noarch
Comment 7 errata-xmlrpc 2016-02-18 11:10:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0259.html

Note You need to log in before you can comment on or make changes to this bug.