Bug 1299414 - DWH: Update the dist git repo to keep upstream package name
DWH: Update the dist git repo to keep upstream package name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Shirly Radco
Lukas Svaty
:
: 1299415 (view as bug list)
Depends On:
Blocks: 1251129
  Show dependency treegraph
 
Reported: 2016-01-18 05:27 EST by Shirly Radco
Modified: 2016-08-23 17:10 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 17:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shirly Radco 2016-01-18 05:27:50 EST
Description of problem:

According to Bug 1251129 - [RFE] Drop renaming of ovirt prefixed packages to rhevm prefixed packages
We need to keep ovirt prefix in dowsntream package.

Example for change in downstream spec file
name: ovirt-engine-dwh
version: 4.0.0
provides: rhevm-dwh = 4.0.0
obsoletes: rhevm-dwh < 4.0
Comment 1 Michal Skrivanek 2016-01-22 09:23:09 EST
*** Bug 1299415 has been marked as a duplicate of this bug. ***
Comment 3 Sandro Bonazzola 2016-02-19 10:56:13 EST
(In reply to Shirly Radco from comment #0)
> Description of problem:
> 
> According to Bug 1251129 - [RFE] Drop renaming of ovirt prefixed packages to
> rhevm prefixed packages
> We need to keep ovirt prefix in dowsntream package.
> 
> Example for change in downstream spec file
> name: ovirt-engine-dwh
> version: 4.0.0
> provides: rhevm-dwh = 4.0.0
> obsoletes: rhevm-dwh < 4.0

Thinking about it, there's no need to use provides and obsoletes here.
rhevm-dwh doesn't exist on EL7 so it can't be upgraded.
Comment 8 errata-xmlrpc 2016-08-23 17:10:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1691.html

Note You need to log in before you can comment on or make changes to this bug.