Bug 1299566 - Shelve instance has no icon in toolbar
Shelve instance has no icon in toolbar
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: Eric Winchell
Ola Pavlenko
ui:openstack
: ZStream
: 1302158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 11:17 EST by Pete Savage
Modified: 2017-08-29 23:45 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 14:41:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2016-01-18 11:17:25 EST
Description of problem: Shelve instance has no icon in toolbar


Version-Release number of selected component (if applicable): 5.5.2.1


How reproducible: 100%

Steps to Reproduce:
1. Add a RHOS provider with instances
2. Go to Clouds -> Instances
3. Click on a checkbox next to and instance and select the Power Menu

Actual results: Shelve and Shelve Offload options have no icons


Expected results: Shelve and Shelve Offload options should have icons


Additional info:
Comment 3 Eric Winchell 2016-01-27 16:02:02 EST
*** Bug 1302158 has been marked as a duplicate of this bug. ***
Comment 4 Pete Savage 2016-01-28 06:01:26 EST
[----] F, [2016-01-28T05:54:55.690638 #2973:12ab998] FATAL -- : 
ActionController::RoutingError (No route matches [GET] "/images/toolbars/power_shelve_offload.png"):
  actionpack (4.2.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
  railties (4.2.5) lib/rails/rack/logger.rb:38:in `call_app'
  railties (4.2.5) lib/rails/rack/logger.rb:22:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/request_id.rb:21:in `call'
  rack (1.6.4) lib/rack/methodoverride.rb:22:in `call'
  rack (1.6.4) lib/rack/runtime.rb:18:in `call'
  activesupport (4.2.5) lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
  rack (1.6.4) lib/rack/lock.rb:17:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/static.rb:116:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/static.rb:116:in `call'
  rack (1.6.4) lib/rack/sendfile.rb:113:in `call'
  railties (4.2.5) lib/rails/engine.rb:518:in `call'
  railties (4.2.5) lib/rails/application.rb:165:in `call'
  rack (1.6.4) lib/rack/content_length.rb:15:in `call'
  thin (1.6.3) lib/thin/connection.rb:86:in `block in pre_process'
  thin (1.6.3) lib/thin/connection.rb:84:in `catch'
  thin (1.6.3) lib/thin/connection.rb:84:in `pre_process'
  thin (1.6.3) lib/thin/connection.rb:53:in `process'
  thin (1.6.3) lib/thin/connection.rb:39:in `receive_data'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run_machine'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run'
  thin (1.6.3) lib/thin/backends/base.rb:73:in `start'
  thin (1.6.3) lib/thin/server.rb:162:in `start'
  rack (1.6.4) lib/rack/handler/thin.rb:19:in `run'
  rack (1.6.4) lib/rack/server.rb:286:in `start'
  railties (4.2.5) lib/rails/commands/server.rb:80:in `start'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:80:in `block in server'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:75:in `tap'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:75:in `server'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:39:in `run_command!'
  railties (4.2.5) lib/rails/commands.rb:17:in `<top (required)>'
  bin/rails:4:in `require'
  bin/rails:4:in `<main>'


AND


[----] F, [2016-01-28T05:54:11.509783 #2973:12ab998] FATAL -- : 
ActionController::RoutingError (No route matches [GET] "/images/toolbars/power_shelve.png"):
  actionpack (4.2.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
  railties (4.2.5) lib/rails/rack/logger.rb:38:in `call_app'
  railties (4.2.5) lib/rails/rack/logger.rb:22:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/request_id.rb:21:in `call'
  rack (1.6.4) lib/rack/methodoverride.rb:22:in `call'
  rack (1.6.4) lib/rack/runtime.rb:18:in `call'
  activesupport (4.2.5) lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
  rack (1.6.4) lib/rack/lock.rb:17:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/static.rb:116:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/static.rb:116:in `call'
  rack (1.6.4) lib/rack/sendfile.rb:113:in `call'
  railties (4.2.5) lib/rails/engine.rb:518:in `call'
  railties (4.2.5) lib/rails/application.rb:165:in `call'
  rack (1.6.4) lib/rack/content_length.rb:15:in `call'
  thin (1.6.3) lib/thin/connection.rb:86:in `block in pre_process'
  thin (1.6.3) lib/thin/connection.rb:84:in `catch'
  thin (1.6.3) lib/thin/connection.rb:84:in `pre_process'
  thin (1.6.3) lib/thin/connection.rb:53:in `process'
  thin (1.6.3) lib/thin/connection.rb:39:in `receive_data'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run_machine'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run'
  thin (1.6.3) lib/thin/backends/base.rb:73:in `start'
  thin (1.6.3) lib/thin/server.rb:162:in `start'
  rack (1.6.4) lib/rack/handler/thin.rb:19:in `run'
  rack (1.6.4) lib/rack/server.rb:286:in `start'
  railties (4.2.5) lib/rails/commands/server.rb:80:in `start'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:80:in `block in server'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:75:in `tap'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:75:in `server'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:39:in `run_command!'
  railties (4.2.5) lib/rails/commands.rb:17:in `<top (required)>'
  bin/rails:4:in `require'
  bin/rails:4:in `<main>'
Comment 6 CFME Bot 2016-02-10 14:00:51 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e434b6b160110dbd0b09adc7d5dbee5be1f9f629

commit e434b6b160110dbd0b09adc7d5dbee5be1f9f629
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Thu Jan 28 09:59:18 2016 -0500
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Thu Jan 28 16:45:27 2016 -0500

    add missing icons
    https://bugzilla.redhat.com/show_bug.cgi?id=1299566

 public/images/toolbars/power_shelve.png         | Bin 0 -> 613 bytes
 public/images/toolbars/power_shelve_offload.png | Bin 0 -> 613 bytes
 2 files changed, 0 insertions(+), 0 deletions(-)
 create mode 100644 public/images/toolbars/power_shelve.png
 create mode 100644 public/images/toolbars/power_shelve_offload.png
Comment 7 CFME Bot 2016-02-10 14:02:00 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=65bd384846557c2deaf1687f9830aca53c2680a3

commit 65bd384846557c2deaf1687f9830aca53c2680a3
Merge: d725dbd e434b6b
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Feb 10 13:46:35 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Feb 10 13:46:35 2016 -0500

    Merge branch '1299566' into '5.5.z'
    
    add missing icons
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299566
    
    See merge request !758

 public/images/toolbars/power_shelve.png         | Bin 0 -> 613 bytes
 public/images/toolbars/power_shelve_offload.png | Bin 0 -> 613 bytes
 2 files changed, 0 insertions(+), 0 deletions(-)
Comment 9 Ronnie Rasouli 2016-04-05 05:07:07 EDT
shelve, shelve_offload have icons
Comment 11 errata-xmlrpc 2016-04-13 14:41:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.