Bug 1299577 - fence_compute.py: Fix 'evacute' typo
fence_compute.py: Fix 'evacute' typo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Marek Grac
Asaf Hirshberg
: ZStream
Depends On: 1283084
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 11:43 EST by Marcel Kolaja
Modified: 2016-02-16 06:23 EST (History)
12 users (show)

See Also:
Fixed In Version: fence-agents-4.0.11-27.el7.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283084
Environment:
Last Closed: 2016-02-16 06:23:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2016-01-18 11:43:18 EST
This bug has been copied from bug #1283084 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Asaf Hirshberg 2016-02-01 08:49:31 EST
Verified on Rhel7.2.

[root@overcloud-controller-0 openstack]# grep -n evacuate* NovaCompute
110:<parameter name="evacuation_delay" unique="0" required="0">
112:How long to wait for nova to finish evacuating instances elsewhere
114:evacuations might be in progress.
118:<shortdesc lang="en">Delay to allow evacuations time to complete</shortdesc>
167:	: has been evacuated, however it could have been 1s ago
168:	ocf_log info "Pausing to give evacuations from ${NOVA_HOST} time to complete"
169:	sleep ${OCF_RESKEY_evacuation_delay}
172:	ocf_log info "Waiting for pending evacuations from ${NOVA_HOST}"
178:	ocf_log info "Pausing to give evacuations from ${NOVA_HOST} time to complete"
179:	sleep ${OCF_RESKEY_evacuation_delay}
344:: ${OCF_RESKEY_evacuation_delay=120}
[root@overcloud-controller-0 openstack]# grep -n evacuate* NovaEvacuate 
48:Facility for tacking a list of compute nodes and reliably evacuating the ones that fence_evacuate has flagged.
124:evacuate_usage() {
132:evacuate_stop() {
137:evacuate_start() {
143:update_evacuation() {
147:	ocf_log warn "Can not set evacuation state of ${1} to ${2}: ${arc}"
152:handle_evacuations() {
157:	need_evacuate=0
162:	    yes) need_evacuate=1;; 
169:		    ocf_log info "Processing partial evacuation of $node by $where at $when"		
170:		    need_evacuate=1
172:		    # Give some time for any in-flight evacuations to either complete or fail
174:		    ocf_log info "Deferring processing partial evacuation of $node by $where at $when"
179:	if [ $need_evacuate = 1 ]; then
181:	    ocf_log notice "Initiating evacuation of $node"
196:	    update_evacuation ${node} "$(uname -n)@$(date +%s)"
205:		update_evacuation ${node} no
206:		ocf_log notice "Completed evacuation of $node"
209:		update_evacuation ${node} yes
217:evacuate_monitor() {
222:    handle_evacuations $(attrd_updater -n evacute -A | tr '="' '  ' | awk '{print $4" "$6}')
226:evacuate_validate() {
295:start)		evacuate_validate; evacuate_start;;
296:stop)		evacuate_stop;;
297:monitor)	evacuate_validate; evacuate_monitor;;
301:usage|help)	evacuate_usage
305:*)		evacuate_usage
[root@overcloud-controller-0 openstack]#
Comment 7 errata-xmlrpc 2016-02-16 06:23:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0207.html

Note You need to log in before you can comment on or make changes to this bug.