Bug 129962 - liblow.c error - no mouse and incorrect keypad keys
liblow.c error - no mouse and incorrect keypad keys
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido INOUE
David Lawrence
:
: 137284 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-15 16:22 EDT by Robert Couture
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.20.1-61
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 17:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace output from strace mc >selected file.txt (53.63 KB, text/plain)
2004-08-15 18:41 EDT, Jim Cornette
no flags Details

  None (edit)
Description Robert Couture 2004-08-15 16:22:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Fire up mc in either Gnome or Console the following error is at the
bottom of the mc screen"

*** err [lib/liblow.c(268)]: strncmp/isdigit/consolename failed

The noticed results are (but may not be related) No mouse functions in
mc and keypad chars are incorrect.

This occured after a fresh install of FC3t1 and doing the first
available updates.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start mc in a Gnome or Konsole window.
2.
3.
    

Actual Results:  Get *** err [lib/liblow.c(268)]:
strncmp/isdigit/consolename failed error every time.

Expected Results:  No error.

Additional info:
Comment 1 Jim Cornette 2004-08-15 18:41:43 EDT
Created attachment 102753 [details]
strace output from strace mc >selected file.txt

I did not notice this error previous to discussions on the test list. I see the
same arror which Robert describes.
This error showed in both a tty terminal and within a gnome-terminal.

Great catch Robert!
Comment 2 Eido INOUE 2004-10-27 11:43:23 EDT
*** Bug 137284 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.