Bug 137284 - liblow.c needs fixes for w3m in screen
liblow.c needs fixes for w3m in screen
Status: CLOSED DUPLICATE of bug 129962
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-10-27 04:40 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-10-27 04:40:17 EDT
Description of problem: Run w3m while you're in a screen, and you get
the error:

*** err [lib/liblow.c(268)]: strncmp/isdigit/consolename failed

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start screen
2. Start w3m. Do w3m www.redhat.com
3. Look at error in top left hand corner of screen
Actual results:
Error message displayed at the top-left hand corner of the window
*** err [lib/liblow.c(268)]: strncmp/isdigit/consolename failed

Expected results:
No errors

Additional info:
Passing -no-mouse to w3m will solve this "problem". So I took a poke
at the code... and there are comments saying: "do we really need this
check ?" <-- so maybe we can drop the check and solve it ;)

Tried on rawhide latest/ppc, and on an FC2 machine thats x86 (if
required I'll test on rawhide x86, later...)
Comment 1 Eido Inoue 2004-10-27 11:43:16 EDT
code has been commented out and already fixed in gpm release 66

*** This bug has been marked as a duplicate of 129962 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.