Bug 1299655 - rhel-osp-director: deployment fails: did not find expected key while parsing a block mapping at line 2 column 1 at /var/lib/heat-config/heat-config-puppet/dca5f578-c9f9-4e50-8a23-11c78b5665ee.pp:51 on node overcloud-controller-0.localdomain
Summary: rhel-osp-director: deployment fails: did not find expected key while parsing ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Marios Andreou
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-18 22:22 UTC by Alexander Chuzhoy
Modified: 2016-04-18 07:13 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-107.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-18 16:50:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Alexander Chuzhoy 2016-01-18 22:22:26 UTC
rhel-osp-director: ipv6 deployment fails:
 "Error: (<unknown>): did not find expected key while parsing a block mapping at line 2 column 1 at /var/lib/heat-config/heat-config-puppet/1f71c3ac-1607-437c-a2d0-82cf685b1425.pp:51 on node overcloud-controller-2.localdomain\n


Environment:
instack-undercloud-2.1.2-37.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-106.el7ost.noarch




Steps to reproduce:

Attempt to deploy overcloud with ipv6:

openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation-v6.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml -e /home/stack/network-environment.yaml ....

Comment 2 Alexander Chuzhoy 2016-01-19 01:35:23 UTC
Reproduced on a deployment with ipv4.

Comment 3 Alexander Chuzhoy 2016-01-19 02:58:28 UTC
There's a problem running hiera

Comment 4 Alexander Chuzhoy 2016-01-19 03:01:27 UTC
Running 'hiera mysql::server::package_name' results in:

/usr/share/ruby/psych.rb:205:in `parse': (<unknown>): did not find expected key while parsing a block mapping at line 2 column 1 (Psych::SyntaxError)
        from /usr/share/ruby/psych.rb:205:in `parse_stream'
        from /usr/share/ruby/psych.rb:153:in `parse'
        from /usr/share/ruby/psych.rb:129:in `load'
        from /usr/share/ruby/vendor_ruby/hiera/backend/yaml_backend.rb:18:in `block (2 levels) in lookup'
        from /usr/share/ruby/vendor_ruby/hiera/filecache.rb:53:in `read_file'
        from /usr/share/ruby/vendor_ruby/hiera/backend/yaml_backend.rb:17:in `block in lookup'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:104:in `block in datasourcefiles'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:76:in `block in datasources'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:74:in `map'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:74:in `datasources'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:99:in `datasourcefiles'
        from /usr/share/ruby/vendor_ruby/hiera/backend/yaml_backend.rb:16:in `lookup'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:206:in `block in lookup'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:203:in `each'
        from /usr/share/ruby/vendor_ruby/hiera/backend.rb:203:in `lookup'
        from /usr/share/ruby/vendor_ruby/hiera.rb:60:in `lookup'
        from /bin/hiera:225:in `<main>'



Environment:
hiera-1.3.4-1.el7.noarch

Comment 5 Dan Sneddon 2016-01-19 08:21:29 UTC
I reproduced this error in my environment:

    "deploy_stderr": "Device \"br_ex\" does not exist.\nDevice \"ovs_system\" does not exist.\n\u001b[1;31mError: (<unknown>): did not find expected key while parsing a block mapping at line 2 column 1 at /var/lib/heat-config/heat-config-puppet/9ace68af-ed86-4998-997b-35cbb77738d5.pp:18 on node overcloud-compute-0.localdomain\nWrapped exception:\n(<unknown>): did not find expected key while parsing a block mapping at line 2 column 1\u001b[0m\n\u001b[1;31mError: (<unknown>): did not find expected key while parsing a block mapping at line 2 column 1 at /var/lib/heat-config/heat-config-puppet/9ace68af-ed86-4998-997b-35cbb77738d5.pp:18 on node overcloud-compute-0.localdomain\u001b[0m\n"

Comment 6 Marios Andreou 2016-01-19 09:39:56 UTC
fwiw: I just deployed using re-built images, after getting latest tripleo-heat-templates, openstack-puppet-modules and python-memcached for bug 1299265 - on my undercloud:

[stack@instack ~]$ rpm -qa | grep "openstack-puppet-modules\|tripleo\|python-memcached"
openstack-puppet-modules-2015.1.8-41.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
python-memcached-1.53-3.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-5.git49b57eb.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-106.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch


Deployed using built images, the stack goes to CREATE_COMPLETE 
(though deploy fails because of the final v6 route missing from undercloud AuthorizationFailure: Authorization Failed: Unable to establish connection to http://[2001:db8:fd00:1000:f816:3eff:fe37:af72]:5000/v2.0/tokens)...

Trying the repro above:

[root@overcloud-controller-0 heat-admin]# hiera mysql::server::package_name
mariadb-galera-server

[root@overcloud-controller-0 heat-admin]# rpm -qa | grep "puppet-modules\|hiera"
openstack-puppet-modules-2015.1.8-41.el7ost.noarch
hiera-1.3.4-1.el7.noarch

[root@overcloud-compute-0 heat-admin]# hiera mysql::server::package_name
mariadb-galera-server

[root@overcloud-controller-0 heat-admin]# rpm -qa | grep "puppet-modules\|hiera"
openstack-puppet-modules-2015.1.8-41.el7ost.noarch

Comment 7 Marios Andreou 2016-01-19 09:46:37 UTC
One thing i just noticed is I have an earlier instack-undercloud (not sure if relevant yet, reporting to match sasha debug info in description above)


[stack@instack ~]$ rpm -qa | grep instack-undercloud
instack-undercloud-2.1.2-36.el7ost.noarch

Comment 8 Marios Andreou 2016-01-19 10:37:25 UTC
Update: CAN reproduce this with --control-scale 3, poking (is related to the fixup for bug 1299265 unfortunately  - didn't have time to check the 3 control before leaving last night.

Comment 12 errata-xmlrpc 2016-02-18 16:50:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.