Bug 1299737 - values for Number of Scrubbed files, Number of Unsigned files, Last completed scrub time and Duration of last scrub are shown as zeros in bit rot scrub status
values for Number of Scrubbed files, Number of Unsigned files, Last completed...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: bitrot (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Kotresh HR
Sweta Anandpara
: ZStream
Depends On: 1285226 1329211 1332072
Blocks: 1260783 1299184
  Show dependency treegraph
 
Reported: 2016-01-19 02:18 EST by Vivek Agarwal
Modified: 2016-09-17 10:22 EDT (History)
15 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-4
Doc Type: Bug Fix
Doc Text:
New statistics have been added to the output of 'gluster volume bitrot $volname scrub status'. The following additional statistics are now output: number of scrubbed files, number of skipped files, last completed scrub time, and duration of last scrub.
Story Points: ---
Clone Of: 1285226
: 1329211 (view as bug list)
Environment:
Last Closed: 2016-06-23 01:02:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Kotresh HR 2016-04-26 00:37:33 EDT
Patch posted Upstream:

http://review.gluster.org/#/c/14044/
Comment 7 Sweta Anandpara 2016-05-31 04:31:26 EDT
Tested and verified this on the build 3.7.9-6.

Have raised new BZs for issues found regarding scrub status output. Thus, moving this blanket-BZ to verified in 3.1.3.
Comment 9 Kotresh HR 2016-06-10 01:43:26 EDT
Laura,

----
When users ran 'gluster volume bitrot $volname scrub status', several statistics were reported as zeroes. The following statistics now display correctly: number of scrubbed files, number of unsigned files, last completed scrub time, and duration of last scrub.
----

The above doc text says, several statistics were reported as zeroes. But since they were reporting zeroes, we had masked them not to show in previous release.
So the following fields were not being shown at all in previous release.
number of scrubbed files, number of unsigned files, last completed scrub time, and duration of last scrub.

Now we show them with accurate values.

So the correction would be to say.

-------
When users ran 'gluster volume bitrot $volname scrub status', the following additional statistics would be displayed: number of scrubbed files, number of unsigned files, last completed scrub time, and duration of last scrub.
-------
Comment 11 Kotresh HR 2016-06-10 10:46:35 EDT
Doc Text looks fine to me.
Comment 12 Sweta Anandpara 2016-06-13 03:09:51 EDT
Hi Laura, 

Could you please change the the field 'number of unsigned files' to 'number of skipped files' ? That is how it actually gets shown in the scrub status output. Have pasted a sample output below for your reference. 

[root@dhcp47-188 ~]# gluster v bitrot disp scrub status

Volume name : disp

State of scrub: Active

Scrub impact: lazy

Scrub frequency: hourly

Bitrot error log location: /var/log/glusterfs/bitd.log

Scrubber error log location: /var/log/glusterfs/scrub.log


=========================================================

Node: localhost

Number of Scrubbed files: 22

Number of Skipped files: 0

Last completed scrub time: 2016-06-05 10:53:58

Duration of last scrub (D:M:H:M:S): 0:0:0:14

Error count: 0


=========================================================

Node: 10.70.46.193

Number of Scrubbed files: 0

Number of Skipped files: 0

Last completed scrub time: Scrubber pending to complete.

Duration of last scrub (D:M:H:M:S): 0:0:0:0

Error count: 0


=========================================================

Node: 10.70.46.215

Number of Scrubbed files: 22

Number of Skipped files: 0

Last completed scrub time: 2016-06-05 10:56:57

Duration of last scrub (D:M:H:M:S): 0:0:0:13

Error count: 0


=========================================================

Node: 10.70.46.187

Number of Scrubbed files: 22

Number of Skipped files: 0

Last completed scrub time: 2016-06-05 10:57:03

Duration of last scrub (D:M:H:M:S): 0:0:0:13

Error count: 0

=========================================================

[root@dhcp47-188 ~]#
Comment 13 Sweta Anandpara 2016-06-13 03:13:02 EDT
Please do acknowledge. Thanks.
Comment 16 errata-xmlrpc 2016-06-23 01:02:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.