Bug 1299760 - Can't rebuild parallel.src.rpm on RHEL 7.2
Can't rebuild parallel.src.rpm on RHEL 7.2
Status: CLOSED DUPLICATE of bug 1285888
Product: Fedora
Classification: Fedora
Component: parallel (Show other bugs)
24
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Golo Fuchert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 04:01 EST by Alexander Todorov
Modified: 2016-04-03 17:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-03 17:57:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2016-01-19 04:01:01 EST
Description of problem:

# rpmbuild --rebuild parallel-20141122-2.fc23.src.rpm 
Installing parallel-20141122-2.fc23.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.6jdukt
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd /root/rpmbuild/BUILD
+ rm -rf parallel-20141122
+ /usr/bin/bzip2 -dc /root/rpmbuild/SOURCES/parallel-20141122.tar.bz2
+ /usr/bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd parallel-20141122
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.ECuFUm
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd parallel-20141122
+ CFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic'
+ export CFLAGS
+ CXXFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic'
+ export CXXFLAGS
+ FFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -I/usr/lib64/gfortran/modules'
+ export FFLAGS
+ FCFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -I/usr/lib64/gfortran/modules'
+ export FCFLAGS
+ LDFLAGS='-Wl,-z,relro '
+ export LDFLAGS
+ '[' 1 == 1 ']'
+ '[' x86_64 == ppc64le ']'
++ find . -name config.guess -o -name config.sub
+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info
configure: WARNING: unrecognized options: --disable-dependency-tracking
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether ln -s works... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating config.h
configure: WARNING: unrecognized options: --disable-dependency-tracking
+ make -j8
make  all-recursive
make[1]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122'
Making all in src
make[2]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122/src'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122/src'
make[2]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122'
make[2]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122'
make[1]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122'
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.ooKEPi
+ umask 022
+ cd /root/rpmbuild/BUILD
+ '[' /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64 '!=' / ']'
+ rm -rf /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64
++ dirname /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64
+ mkdir -p /root/rpmbuild/BUILDROOT
+ mkdir /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64
+ cd parallel-20141122
+ make install DESTDIR=/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64
Making install in src
make[1]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122/src'
make[2]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122/src'
 /usr/bin/mkdir -p '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/bin'
 /usr/bin/install -c parallel sql niceload '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/bin'
make  install-exec-hook
make[3]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122/src'
rm /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/bin/sem || true
rm: cannot remove '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/bin/sem': No such file or directory
ln -s parallel /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/bin/sem
make[3]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122/src'
 /usr/bin/mkdir -p '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel'
 /usr/bin/install -c -m 644 parallel.html sem.html sql.html niceload.html parallel_tutorial.html parallel.texi sem.texi sql.texi niceload.texi parallel_tutorial.texi parallel.pdf sem.pdf sql.pdf niceload.pdf parallel_tutorial.pdf '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel'
 /usr/bin/mkdir -p '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/man/man1'
 /usr/bin/install -c -m 644 parallel.1 sem.1 sql.1 niceload.1 parallel_tutorial.1 '/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/man/man1'
make[2]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122/src'
make[1]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122/src'
make[1]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122'
make[2]: Entering directory `/root/rpmbuild/BUILD/parallel-20141122'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122'
make[1]: Leaving directory `/root/rpmbuild/BUILD/parallel-20141122'
+ find /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64 -iname '*.html' -delete
+ find /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64 -iname '*.texi' -delete
+ find /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64 -iname '*.pod' -delete
+ mv /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/man/man1/sql.1 /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/man/man1/parallel-sql.1
+ /usr/lib/rpm/find-debuginfo.sh --strict-build-id -m --run-dwz --dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 110000000 /root/rpmbuild/BUILD/parallel-20141122
/usr/lib/rpm/sepdebugcrcfix: Updated 0 CRC32s, 0 CRC32s did match.
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+ /usr/lib/rpm/redhat/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: parallel-20141122-2.el7.noarch
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.019n2e
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd parallel-20141122
+ DOCDIR=/root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ export DOCDIR
+ /usr/bin/mkdir -p /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr README /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr NEWS /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr COPYING /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr src/parallel.html /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr src/sem.html /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr src/sql.html /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr src/niceload.html /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ cp -pr src/niceload.texi src/parallel.texi src/parallel_tutorial.texi src/sem.texi src/sql.texi /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64/usr/share/doc/parallel-20141122
+ exit 0
Provides: parallel = 20141122-2.el7
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: /usr/bin/env /usr/bin/perl perl(File::Basename) perl(File::Path) perl(File::Temp) perl(FileHandle) perl(Getopt::Long) perl(IPC::Open3) perl(POSIX) perl(Symbol) perl(strict)
Conflicts: moreutils-parallel
Checking for unpackaged file(s): /usr/lib/rpm/check-files /root/rpmbuild/BUILDROOT/parallel-20141122-2.el7.x86_64
error: Installed (but unpackaged) file(s) found:
   /usr/share/doc/parallel/niceload.pdf
   /usr/share/doc/parallel/parallel.pdf
   /usr/share/doc/parallel/parallel_tutorial.pdf
   /usr/share/doc/parallel/sem.pdf
   /usr/share/doc/parallel/sql.pdf


RPM build errors:
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    Installed (but unpackaged) file(s) found:
   /usr/share/doc/parallel/niceload.pdf
   /usr/share/doc/parallel/parallel.pdf
   /usr/share/doc/parallel/parallel_tutorial.pdf
   /usr/share/doc/parallel/sem.pdf
   /usr/share/doc/parallel/sql.pdf



Version-Release number of selected component (if applicable):
parallel-20141122-2.fc23.src.rpm


How reproducible:
Always

Steps to Reproduce:
1. Rebuild the latest src.rpm on RHEL 7.2


The offending PDF files come from the source tarball. 

Adding to %install
find %{buildroot} -iname "*.pdf" -delete

fixed it for me.
Comment 1 Jan Kurik 2016-02-24 10:52:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Golo Fuchert 2016-04-03 17:57:52 EDT

*** This bug has been marked as a duplicate of bug 1285888 ***

Note You need to log in before you can comment on or make changes to this bug.