Bug 1299795 - Unable to register overcloud hosts to RHN network through overcloud deploy
Unable to register overcloud hosts to RHN network through overcloud deploy
Status: CLOSED DUPLICATE of bug 1293473
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
high Severity high
: y3
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 04:46 EST by Rama
Modified: 2016-04-18 03:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 18:21:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compute Node rhsm log file (2.54 MB, text/plain)
2016-01-19 04:46 EST, Rama
no flags Details

  None (edit)
Description Rama 2016-01-19 04:46:50 EST
Created attachment 1116096 [details]
Compute Node rhsm log file

Description of problem:
Deployed overcloud with the following command
#!/bin/bash
openstack overcloud deploy --templates \
-e /usr/share/openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/templates/network-environment.yaml \
-e /home/stack/templates/storage-environment.yaml \
-e /home/stack/templates/cisco-plugins.yaml \
-e /home/stack/templates/post_config.yaml \
--control-flavor control --compute-flavor compute --ceph-storage-flavor CephStorage \
--compute-scale 6 --control-scale 3  --ceph-storage-scale 3 \
--libvirt-type kvm \
--ntp-server 171.68.38.66 \
--neutron-network-type vlan \
--neutron-tunnel-type vlan \
--neutron-bridge-mappings datacentre:br-ex,physnet-tenant:br-tenant,floating:br-floating \
--neutron-network-vlan-ranges physnet-tenant:250:749,floating:160:160 \
--neutron-disable-tunneling --timeout 300 \
--rhel-reg --reg-method portal --reg-org <orgid> --reg-activation-key <mykey> \
--verbose --debug --log-file overcloud_new.log

Overcloud gets deployed but servers are not registered with the network.

Version-Release number of selected component (if applicable):
OSP7 y2 on RHEL 7.2

How reproducible:
Always

Steps to Reproduce:
1.Run deploy and try to register with the servers with RHN network
2.
3.

Actual results:
The registration shows as unknown status with subscription-manager command.

Expected results:


Additional info:

After this I tried to manually register the servers as below and it works fine.
[stack@osp7-director ~]$ for i in $(nova list | awk '/ACTIVE/ {print $12}'|cut -d "=" -f2 ) ; do ssh -l heat-admin $i "sudo subscription-manager
 register --activationkey=$KEY --org=$ORG"; done 
The system has been registered with ID: 9d6d5759-9eb6-445e-8b0b-b7e85bd4e5ac 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

The system has been registered with ID: 974b24a1-138c-468b-b112-4096f26cdc17 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

The system has been registered with ID: bb1312cd-0d13-4e29-84b5-fb35f22313c9 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

The system has been registered with ID: e4f0f17e-51fd-4c9c-b303-967aba0e51dc 

... 
Could register all the 12 servers in the pod this way.
Comment 2 Jaromir Coufal 2016-01-26 18:21:39 EST
Hi Rama,

there is no support of RHN registration in OSP-d 7.2. We are adding support for Sat5 integration / RHN registration in OSP-d 7.3. This was already requested in another bugzilla RFE and the work is tracked there.

I will close this one as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1293473.

Thanks
-- Jarda

*** This bug has been marked as a duplicate of bug 1293473 ***

Note You need to log in before you can comment on or make changes to this bug.