Bug 1299819 - Snapshot creation fails on a tiered volume
Snapshot creation fails on a tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Avra Sengupta
: ZStream
Depends On: 1299799
Blocks: 1299822
  Show dependency treegraph
 
Reported: 2016-01-19 05:38 EST by Avra Sengupta
Modified: 2016-06-16 09:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1299799
: 1299822 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-19 05:55:40 EST
REVIEW: http://review.gluster.org/13260 (snapshot: Return before redundant quorum check) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-01-20 01:57:57 EST
COMMIT: http://review.gluster.org/13260 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit de276bd2452302e2e27b94b7f577c25fc351037d
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue Jan 19 16:22:17 2016 +0530

    snapshot: Return before redundant quorum check
    
    As of today, we don't support creation of snapshot even
    if one brick is down. Hence the older quorum check is
    redundant. Returning after performing the check to
    see if all bricks are up.
    
    BUG: 1299819
    Change-Id: I35661d05a15be0109aaae51b4fe0d5a8ca4333ad
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13260
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:55:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.