Bug 1299822 - Snapshot creation fails on a tiered volume
Snapshot creation fails on a tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.7
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
: Triaged, ZStream
Depends On: 1299799 1299819
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 05:41 EST by Avra Sengupta
Modified: 2016-04-19 03:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1299819
Environment:
Last Closed: 2016-02-15 07:15:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-19 06:31:26 EST
REVIEW: http://review.gluster.org/13261 (snapshot: Return before redundant quorum check) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-01-20 01:57:30 EST
COMMIT: http://review.gluster.org/13261 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b273915811fc484698a46f36597581dd0a5753e7
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue Jan 19 16:22:17 2016 +0530

    snapshot: Return before redundant quorum check
    
        Backport of http://review.gluster.org/#/c/13260/
    
    As of today, we don't support creation of snapshot even
    if one brick is down. Hence the older quorum check is
    redundant. Returning after performing the check to
    see if all bricks are up.
    
    Change-Id: I35661d05a15be0109aaae51b4fe0d5a8ca4333ad
    BUG: 1299822
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13261
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.