Bug 1299953 - Glance client error using IPv6 - ValueError: invalid literal for int() with base 10: 'fd00'
Glance client error using IPv6 - ValueError: invalid literal for int() with b...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity urgent
: y3
: 7.0 (Kilo)
Assigned To: Emilien Macchi
yeylon@redhat.com
: Automation, AutomationBlocker, ZStream
Depends On: 1299855
Blocks: 1312983
  Show dependency treegraph
 
Reported: 2016-01-19 10:34 EST by Mike Burns
Modified: 2016-04-26 16:52 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.6-109.el7ost
Doc Type: Bug Fix
Doc Text:
Overcloud deployments with IPv6 endpoints caused Glance to report a HTTP 500 error. This is due to how the director parsed IPv6 addresses. This fix corrects how the director parses the IPv6 address for Glance. Glance now works in IPv6-based Overclouds.
Story Points: ---
Clone Of: 1299855
: 1312983 (view as bug list)
Environment:
Last Closed: 2016-02-18 11:50:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Lon Hohberger 2016-01-19 10:45:38 EST
Upstream gerrit review https://review.openstack.org/#/c/83586/ seems relevant but imports network_utils which do not exist in glanceclient 0.17.3.

This could be a rebase or a more extensive backport, but great care must be taken to preserve API / cmdline stability.
Comment 2 Flavio Percoco 2016-01-19 10:49:04 EST
I've commented on the OSP8 patch about where this BZ belongs to. I don't think it'll be possible to backport the fix upstream but it depends on how it is tackled.
Comment 3 Flavio Percoco 2016-01-19 10:50:27 EST
erm, I meant to say the OSP8 BZ ( https://bugzilla.redhat.com/show_bug.cgi?id=1299855#c3 )

Lon, this is not a glanceclient bug :(
Comment 4 Lon Hohberger 2016-01-19 10:52:48 EST
Nope, that's not the right commit - it's been superseded by an import from oslo.utils.
Comment 5 Mike Burns 2016-01-19 14:02:25 EST
Bug 1299855 comment 5 says:

I took a look at the environment and it seems to be a config issue. The registry_host, unlike the bind_host has to be a valid, parsable, ipv6 as it's a string read by glance-api to talk to glance registry. The value in the environment was missing the `[]` which are required by ipv6. Changing it to the one below seemed to have fixed the issue:

registry_host=[fd00:fd00:fd00:2000:f816:3eff:fedb:a219]

moving this to THT
Comment 7 Marius Cornea 2016-01-21 06:35:30 EST
openstack-tripleo-heat-templates-0.8.6-110.el7ost.noarch
Comment 9 errata-xmlrpc 2016-02-18 11:50:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.