Bug 1299965 - Unable to sequence automate class steps
Unable to sequence automate class steps
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity urgent
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Jeff Teehan
:
: 1300369 (view as bug list)
Depends On:
Blocks: 1300034
  Show dependency treegraph
 
Reported: 2016-01-19 10:58 EST by Kevin Morey
Modified: 2016-06-29 11:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1300034 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:31:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Morey 2016-01-19 10:58:28 EST
Description of problem:
We are unable to modify class sequences in the UI.

Version-Release number of selected component (if applicable):
5.5.2.1

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Automate / Explorer
2. Locate a class and attempt to edit the sequence
3. Nothing happens as the UI doesn't allow you to move steps

Actual results:
Nothing happens. The UI doesnt move the steps in the order that you want

Expected results:
to be able to properly order the sequence of steps in a class/state machine

Additional info:
This is a huge one as I had to export the model and edit the yaml file then re-import the class to get the sequence to take.
Comment 2 Harpreet Kataria 2016-01-19 17:05:31 EST
https://github.com/ManageIQ/manageiq/pull/6254
Comment 3 CFME Bot 2016-01-19 19:06:10 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/41c0016d03854e5106b9a188c9c97febf045f916

commit 41c0016d03854e5106b9a188c9c97febf045f916
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Jan 19 17:04:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Jan 19 17:04:27 2016 -0500

    Fixed schema sequencing issue.
    
    Issue is caused by whitespace on the left of all items in list when schema fields do not have display name, when sending up selected fields from the form jquery serialize method trims whitespace around the fields which causes an issue when comparing these fields.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299965
    https://bugzilla.redhat.com/show_bug.cgi?id=1300034

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 37 ++++++++++++++++++++++++
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 5 CFME Bot 2016-01-20 12:29:18 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b2b1d3ccab87d035bb02148c06c450fcfa5924ac

commit b2b1d3ccab87d035bb02148c06c450fcfa5924ac
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Jan 19 17:04:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Jan 20 09:44:22 2016 -0500

    Fixed schema sequencing issue.
    
    Issue is caused by whitespace on the left of all items in list when schema fields do not have display name, when sending up selected fields from the form jquery serialize method trims whitespace around the fields which causes an issue when comparing these fields.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299965
    https://bugzilla.redhat.com/show_bug.cgi?id=1300034
    (cherry picked from commit 41c0016)

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 37 ++++++++++++++++++++++++
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 6 CFME Bot 2016-01-20 12:29:22 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5ef95a93a15619ada226180e78ddc3b7adcba447

commit 5ef95a93a15619ada226180e78ddc3b7adcba447
Merge: 882deee b2b1d3c
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Jan 20 12:27:06 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Jan 20 12:27:06 2016 -0500

    Merge branch '55z_pr_6254' into '5.5.z'
    
    Fixed schema sequencing issue.
    
    Issue is caused by whitespace on the left of all items in list when schema fields do not have display name, when sending up selected fields from the form jquery serialize method trims whitespace around the fields which causes an issue when comparing these fields.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299965
    https://bugzilla.redhat.com/show_bug.cgi?id=1300034
    (cherry picked from commit 41c0016)
    
    @dclarizi please review, this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6254
    
    See merge request !737

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 37 ++++++++++++++++++++++++
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 7 Harpreet Kataria 2016-01-20 12:44:06 EST
*** Bug 1300369 has been marked as a duplicate of this bug. ***
Comment 8 Jeff Teehan 2016-04-25 19:03:41 EDT
I copied the class and instance from the MIQ provision section of the ManageIQ namespace.  From there I was able to modify the sequence and moved the Finished item to the middle of the pack and saved it.

Appears to be working correctly.  Verified using 5.6.0.4 on https://10.16.6.70/miq_ae_class/explorer which will be running for a week or so.
Comment 10 errata-xmlrpc 2016-06-29 11:31:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.