Bug 1300034 - Unable to sequence automate class steps
Unable to sequence automate class steps
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity urgent
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Milan Falešník
: ZStream
Depends On: 1299965
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 14:29 EST by John Prause
Modified: 2016-02-10 10:35 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1299965
Environment:
Last Closed: 2016-02-10 10:35:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Harpreet Kataria 2016-01-19 17:05:39 EST
https://github.com/ManageIQ/manageiq/pull/6254
Comment 3 CFME Bot 2016-01-19 19:06:15 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/41c0016d03854e5106b9a188c9c97febf045f916

commit 41c0016d03854e5106b9a188c9c97febf045f916
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Jan 19 17:04:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Jan 19 17:04:27 2016 -0500

    Fixed schema sequencing issue.
    
    Issue is caused by whitespace on the left of all items in list when schema fields do not have display name, when sending up selected fields from the form jquery serialize method trims whitespace around the fields which causes an issue when comparing these fields.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299965
    https://bugzilla.redhat.com/show_bug.cgi?id=1300034

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 37 ++++++++++++++++++++++++
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 7 CFME Bot 2016-01-20 12:29:26 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5ef95a93a15619ada226180e78ddc3b7adcba447

commit 5ef95a93a15619ada226180e78ddc3b7adcba447
Merge: 882deee b2b1d3c
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Jan 20 12:27:06 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Jan 20 12:27:06 2016 -0500

    Merge branch '55z_pr_6254' into '5.5.z'
    
    Fixed schema sequencing issue.
    
    Issue is caused by whitespace on the left of all items in list when schema fields do not have display name, when sending up selected fields from the form jquery serialize method trims whitespace around the fields which causes an issue when comparing these fields.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299965
    https://bugzilla.redhat.com/show_bug.cgi?id=1300034
    (cherry picked from commit 41c0016)
    
    @dclarizi please review, this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6254
    
    See merge request !737

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 37 ++++++++++++++++++++++++
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 8 CFME Bot 2016-01-20 12:29:30 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b2b1d3ccab87d035bb02148c06c450fcfa5924ac

commit b2b1d3ccab87d035bb02148c06c450fcfa5924ac
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Jan 19 17:04:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Jan 20 09:44:22 2016 -0500

    Fixed schema sequencing issue.
    
    Issue is caused by whitespace on the left of all items in list when schema fields do not have display name, when sending up selected fields from the form jquery serialize method trims whitespace around the fields which causes an issue when comparing these fields.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299965
    https://bugzilla.redhat.com/show_bug.cgi?id=1300034
    (cherry picked from commit 41c0016)

 app/controllers/miq_ae_class_controller.rb       |  2 +-
 spec/controllers/miq_ae_class_controller_spec.rb | 37 ++++++++++++++++++++++++
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 10 Jeff Teehan 2016-01-27 14:06:52 EST
I'm missing something on this bug and will need some help.  Pete is available tomorrow, but if John can help out today, that'd be great.
Comment 12 John Prause 2016-01-27 14:20:38 EST
Sorry,..I only cloned this BZ, so I'm unfamiliar with the issue.
Perhaps Harpreet can assist?
Comment 13 Milan Falešník 2016-01-28 05:30:42 EST
Verified in 5.5.2.2, I created a couple of fields without display name and it worked. I saw this issue in an earlier version so I can say it is rectified now.
Comment 14 errata-xmlrpc 2016-02-10 10:35:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.