Bug 1300152 - Rebalance process crashed during cleanup_and_exit
Summary: Rebalance process crashed during cleanup_and_exit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sakshi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1302962
TreeView+ depends on / blocked
 
Reported: 2016-01-20 03:57 UTC by Sakshi
Modified: 2016-08-01 01:22 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1302962 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:55:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sakshi 2016-01-20 03:57:54 UTC
Description of problem:
Rebalance process crashed during cleanup_and_exit

Version-Release number of selected component (if applicable):


How reproducible:
Observed during upstream regression tests.

Steps to Reproduce:
1.
2.
3.

Actual results:
Rebalance crashes during cleanup_and_exit. From the core that was generated looks like the frame is corrupted.

Expected results:
Rebalance should not crash. 

Additional info:

Comment 1 Vijay Bellur 2016-01-20 05:08:54 UTC
REVIEW: http://review.gluster.org/13262 (glusterfsd: destroy frame after rebalance callback has completed) posted (#1) for review on master by Sakshi Bansal

Comment 2 Vijay Bellur 2016-01-28 06:54:36 UTC
REVIEW: http://review.gluster.org/13262 (glusterfsd: destroy frame after rebalance callback has completed) posted (#2) for review on master by Sakshi Bansal

Comment 3 Vijay Bellur 2016-02-04 09:22:46 UTC
REVIEW: http://review.gluster.org/13262 (glusterfsd: destroy frame after rebalance callback has completed) posted (#3) for review on master by Sakshi Bansal

Comment 4 Vijay Bellur 2016-02-16 02:44:43 UTC
COMMIT: http://review.gluster.org/13262 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 888efdf5e0ab7d22c3fc227dc0dbfaec91b1d5d9
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Wed Jan 20 09:31:00 2016 +0530

    glusterfsd: destroy frame after rebalance callback has completed
    
    Rebalance after sending a status notification immediately
    destroys the frame. Now in its callback the frame is corrupted.
    Rebalance crashes when this corrupted frame is accessed. To avoid
    this we must destroy the frame after the callback is completed.
    
    Change-Id: If383017a61f09275256e51c44a1efa28feace87b
    BUG: 1300152
    Signed-off-by: Sakshi <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13262
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 5 Niels de Vos 2016-06-16 13:55:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.