Bug 1302962 - Rebalance process crashed during cleanup_and_exit
Rebalance process crashed during cleanup_and_exit
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sakshi
:
Depends On: 1300152
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-01-29 02:10 EST by Sakshi
Modified: 2016-07-31 21:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300152
Environment:
Last Closed: 2016-04-15 01:13:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2016-01-29 02:10:12 EST
+++ This bug was initially created as a clone of Bug #1300152 +++

Description of problem:
Rebalance process crashed during cleanup_and_exit

Version-Release number of selected component (if applicable):


How reproducible:
Observed during upstream regression tests.

Steps to Reproduce:
1.
2.
3.

Actual results:
Rebalance crashes during cleanup_and_exit. From the core that was generated looks like the frame is corrupted.

Expected results:
Rebalance should not crash. 

Additional info:
Comment 1 Vijay Bellur 2016-01-29 03:50:25 EST
REVIEW: http://review.gluster.org/13317 (glusterfsd: destroy frame after rebalance callback has completed) posted (#1) for review on release-3.7 by Sakshi Bansal
Comment 2 Vijay Bellur 2016-02-02 00:27:57 EST
REVIEW: http://review.gluster.org/13317 (glusterfsd: destroy frame after rebalance callback has completed) posted (#2) for review on release-3.7 by Sakshi Bansal
Comment 3 Vijay Bellur 2016-02-04 04:22:23 EST
REVIEW: http://review.gluster.org/13317 (glusterfsd: destroy frame after rebalance callback has completed) posted (#3) for review on release-3.7 by Sakshi Bansal
Comment 4 Vijay Bellur 2016-02-15 21:47:04 EST
COMMIT: http://review.gluster.org/13317 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit d516bed538bc09a77f94292de4bb4861da6ace54
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Wed Jan 20 09:31:00 2016 +0530

    glusterfsd: destroy frame after rebalance callback has completed
    
    Rebalance after sending a status notification immediately
    destroys the frame. Now in its callback the frame is corrupted.
    Rebalance crashes when this corrupted frame is accessed. To avoid
    this we must destroy the frame after the callback is completed.
    
    > Backport of http://review.gluster.org/#/c/13262/
    
    > Change-Id: If383017a61f09275256e51c44a1efa28feace87b
    > BUG: 1300152
    > Signed-off-by: Sakshi <sabansal@redhat.com>
    
    Change-Id: If383017a61f09275256e51c44a1efa28feace87b
    BUG: 1302962
    Signed-off-by: Sakshi <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13317
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 5 Kaushal 2016-04-19 03:25:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.