This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300188 - Network status shows "Unknown ovirtmgmt" after register to rhevm3.6 with HE configured
Network status shows "Unknown ovirtmgmt" after register to rhevm3.6 with HE c...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.3
Unspecified Unspecified
high Severity high
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Ryan Barry
cshao
: Reopened, ZStream
Depends On:
Blocks: 1322783
  Show dependency treegraph
 
Reported: 2016-01-20 03:10 EST by cshao
Modified: 2016-06-08 09:04 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1322783 (view as bug list)
Environment:
Last Closed: 2016-06-08 09:03:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network-he (36.80 KB, image/png)
2016-01-20 03:10 EST, cshao
no flags Details
new-he-network (36.92 KB, image/png)
2016-01-27 05:06 EST, cshao
no flags Details
/var/log/*.* + sosreport (13.37 MB, application/x-gzip)
2016-01-27 05:11 EST, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53684 master MERGED Bridge.slave_for_nic needs to exclude vnet devices 2016-03-30 07:04 EDT
oVirt gerrit 55486 ovirt-3.6 MERGED Bridge.slave_for_nic needs to exclude vnet devices 2016-03-30 13:48 EDT

  None (edit)
Description cshao 2016-01-20 03:10:51 EST
Created attachment 1116545 [details]
network-he

Description of problem:
Network status shows "Unknown ovirtmgmt" after register to rhevm3.6 with HE configured, 

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20160113.0
ovirt-node-3.6.1-3.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-6.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-5.el7ev.noarch
hevm-appliance-20151216.0-1.3.6.ova

How reproducible:
100%

Steps to Reproduce:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Configure Hosted engine with correct steps.
4. Reboot host.
5. Focus on network status.

Actual results:
Network status shows "Unknown ovirtmgmt" after register to rhevm3.6 with HE configured, 

Expected results:
It should show "Networking: Connected ovirtmgmt" in status page. 

Additional info:
No such issue if register to RHEV-M directly.
Comment 2 Huijuan Zhao 2016-01-21 22:19:25 EST
Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20160120.0
ovirt-node-3.6.1-3.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-6.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-6.el7ev.noarch
rhevm-appliance-20160120.0-1.3.6.ova


Steps to Reproduce:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Configure Hosted engine with correct steps.
4. Reboot host.
5. Focus on network status.

Test results:
Network status shows "Networking: Connected ovirtmgmt" in status page. configured, 

So this bug is fixed in rhev-hypervisor7-7.2-20160120.0 and rhevm-appliance-20160120.0-1.3.6.ova, when the bug status is ON_QA, we can verify it directly.
Comment 3 cshao 2016-01-27 05:04:59 EST
I have to re-open this bug due to I met this issue twice today.
1. One nic env can reproduce.
2. Bond+vlan env can reproduce.

Test version:
rhev-hypervisor7-7.2-20160126.0
ovirt-node-3.6.1-5.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-6.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
RHEV-appliance-20160120.0-1.3.6.ova  

Test steps:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Configure Hosted engine with correct steps.
4. Reboot host.
5. Focus on network status.

Actual results:
Network status shows "Unknown ovirtmgmt" after register to rhevm3.6 with HE configured, 

Expected results:
It should show "Networking: Connected ovirtmgmt" in status page.
Comment 4 cshao 2016-01-27 05:06 EST
Created attachment 1118731 [details]
new-he-network
Comment 5 cshao 2016-01-27 05:11 EST
Created attachment 1118746 [details]
/var/log/*.* + sosreport
Comment 6 Fabian Deutsch 2016-01-27 07:53:06 EST
Is the network page correct if you got to the RHEV-M page and back to the status page?
Comment 7 cshao 2016-01-27 21:31:49 EST
(In reply to Fabian Deutsch from comment #6)
> Is the network page correct if you got to the RHEV-M page and back to the
> status page?

No, it still show "Networking: unknown ovirtmgmt" after got to the RHEV-M page and back to the status page.
Comment 9 Ryan Barry 2016-02-03 13:42:33 EST
(In reply to shaochen from comment #3)
> I have to re-open this bug due to I met this issue twice today.
> 1. One nic env can reproduce.
> 2. Bond+vlan env can reproduce.
> 
> Test version:
> rhev-hypervisor7-7.2-20160126.0
> ovirt-node-3.6.1-5.0.el7ev.noarch
> ovirt-node-plugin-hosted-engine-0.3.0-6.el7ev.noarch
> ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
> ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
> RHEV-appliance-20160120.0-1.3.6.ova  
> 
> Test steps:
> 1. TUI clean install rhevh
> 2. Login rhevh, setup network via dhcp
> 3. Configure Hosted engine with correct steps.
> 4. Reboot host.
> 5. Focus on network status.
> 
> Actual results:
> Network status shows "Unknown ovirtmgmt" after register to rhevm3.6 with HE
> configured, 
> 
> Expected results:
> It should show "Networking: Connected ovirtmgmt" in status page.

I tried this today with the same rhev-hypervisor image and same rhevm-appliance.

I wasn't able to reproduce it. The status page was correct both before and after rebooting.

I'll try again, but are these the exact steps taken to reproduce?
Comment 10 cshao 2016-02-13 08:36:20 EST
> I tried this today with the same rhev-hypervisor image and same
> rhevm-appliance.
> 
> I wasn't able to reproduce it. The status page was correct both before and
> after rebooting.
> 
> I'll try again, but are these the exact steps taken to reproduce?


Exact steps
1. TUI clean install rhevh on local machine.
2. Login rhevh, setup network via dhcp or bond+vlan.
3. Switch to HE menu
4. File the OVA URL with correct path.
5. Configure Hosted engine with correct steps(NFS type).
6. Finish HE configure.
7. Wait until register done, reboot host.
8. Focus on network status.
Comment 14 Ryan Barry 2016-02-17 18:33:44 EST
This appears to be a duplicate of bz#1280241

I'll look into why the original patch was reverted.

Please try to re-verify bz#1280241.

I'll see if I can rework the follow-up patch to also resolve this.
Comment 15 cshao 2016-02-24 01:00:21 EST
(In reply to Ryan Barry from comment #14)
> This appears to be a duplicate of bz#1280241
> 
> I'll look into why the original patch was reverted.
> 
> Please try to re-verify bz#1280241.
> 
> I'll see if I can rework the follow-up patch to also resolve this.

Done.
Details info please refer bug 1280241 #c19.
Comment 16 Mike McCune 2016-03-28 19:24:30 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 18 Fabian Deutsch 2016-06-08 09:04:16 EDT
This bug got closed, because a code-level fix for this issue will not be available in RHEV 4.0.
But this issue will be fixed from a functional perspective, because the fix to this issue is covered by the migration to Cockpit for administration.

Note You need to log in before you can comment on or make changes to this bug.