Bug 1300231 - 'gluster volume get' returns 0 value for server-quorum-ratio
'gluster volume get' returns 0 value for server-quorum-ratio
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Atin Mukherjee
SATHEESARAN
: ZStream
Depends On:
Blocks: 1299184 1300596 1315939
  Show dependency treegraph
 
Reported: 2016-01-20 05:16 EST by SATHEESARAN
Modified: 2016-09-17 12:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1300596 (view as bug list)
Environment:
Last Closed: 2016-06-23 01:03:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2016-01-20 05:16:53 EST
Description of problem:
-----------------------
Even after setting server quorum ratio, volume get returns the value as 0

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1.2 ( nightly build ) - glusterfs-3.7.5-16.el7rhgs

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Enable server-quorum on the volume
2. Set the server-quorum-ratio to any value , say 80%
3. Get the server-quorum-ration using 'gluster volume get'

Actual results:
---------------
'gluster volume get' returns server-quorum-ratio as 0

Expected results:
-----------------
'gluster volume get' should return the correct value for server-quorum-ratio

Additional info:
----------------

[root@ ~]# gluster volume set all server-quorum-ratio 100%
volume set: success

[root@ ~]# gluster volume get rvolume server-quorum-ratio
Option                                  Value                                   
------                                  -----                                   
cluster.server-quorum-ratio             0                                       

[root@dhcp37-152 ~]# gluster volume get rvolume all | grep server-quorum-ratio
cluster.server-quorum-ratio             0

[root@ ~]# gluster volume info rvolume | grep server-quorum-ratio
cluster.server-quorum-ratio: 100%
Comment 1 Byreddy 2016-01-20 05:44:28 EST
Add to above info.

always (with or without change), the get is returning zero for cluster.server-quorum ratio.
Comment 2 Atin Mukherjee 2016-01-21 04:21:06 EST
Upstream patch http://review.gluster.org/13272 posted for review
Comment 4 Atin Mukherjee 2016-03-22 08:03:32 EDT
The fix is now available in rhgs-3.1.3 branch, hence moving the state to Modified.
Comment 6 SATHEESARAN 2016-03-30 02:43:12 EDT
Tested with RHGS 3.1.3 nightly build ( glusterfs-3.7.9-1.el7rhgs )

[root@ ~]# gluster volume set all server-quorum-ratio 30%

[root@ ~]# gluster volume get test server-quorum-ratio
Option                                  Value                                   
------                                  -----                                   
cluster.server-quorum-ratio             30%
Comment 8 errata-xmlrpc 2016-06-23 01:03:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.