Bug 1300596 - 'gluster volume get' returns 0 value for server-quorum-ratio
'gluster volume get' returns 0 value for server-quorum-ratio
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On: 1300231
Blocks: 1315939
  Show dependency treegraph
 
Reported: 2016-01-21 04:17 EST by Atin Mukherjee
Modified: 2016-06-16 09:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300231
: 1315939 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2016-01-21 04:17:57 EST
+++ This bug was initially created as a clone of Bug #1300231 +++

Description of problem:
-----------------------
Even after setting server quorum ratio, volume get returns the value as 0

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Enable server-quorum on the volume
2. Set the server-quorum-ratio to any value , say 80%
3. Get the server-quorum-ration using 'gluster volume get'

Actual results:
---------------
'gluster volume get' returns server-quorum-ratio as 0

Expected results:
-----------------
'gluster volume get' should return the correct value for server-quorum-ratio

Additional info:
----------------

[root@ ~]# gluster volume set all server-quorum-ratio 100%
volume set: success

[root@ ~]# gluster volume get rvolume server-quorum-ratio
Option                                  Value                                   
------                                  -----                                   
cluster.server-quorum-ratio             0                                       

[root@dhcp37-152 ~]# gluster volume get rvolume all | grep server-quorum-ratio
cluster.server-quorum-ratio             0

[root@ ~]# gluster volume info rvolume | grep server-quorum-ratio
cluster.server-quorum-ratio: 100%

--- Additional comment from Byreddy on 2016-01-20 05:44:28 EST ---

Add to above info.

always (with or without change), the get is returning zero for cluster.server-quorum ratio.
Comment 1 Vijay Bellur 2016-01-21 04:19:53 EST
REVIEW: http://review.gluster.org/13272 (glusterd: volume get should pick options from priv->opts too) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2016-03-04 03:53:16 EST
REVIEW: http://review.gluster.org/13272 (glusterd: volume get should pick options from priv->opts too) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 3 Vijay Bellur 2016-03-06 23:45:54 EST
REVIEW: http://review.gluster.org/13272 (glusterd: volume get should pick options from priv->opts too) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 4 Vijay Bellur 2016-03-08 08:58:31 EST
COMMIT: http://review.gluster.org/13272 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 05d3d95afa62ef3271f0fe3c7272e1e19638c448
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Jan 21 14:48:34 2016 +0530

    glusterd: volume get should pick options from priv->opts too
    
    As of now volume get was not looking for all the global options maintained in
    option dictionary in glusterd_conf_t. This patch includes the same.
    
    Change-Id: Ib05259a2dcacc4a712cae4217fe4a6553b61da56
    BUG: 1300596
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/13272
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:55:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.