This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300243 - Quota Aux mount crashed
Quota Aux mount crashed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: 3.7.5
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1294774 1299497
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 05:41 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1299497
Environment:
Last Closed: 2016-04-19 03:52:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-20 05:41:24 EST
REVIEW: http://review.gluster.org/13267 (quota: start aux mount from glusterd with inet address) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-01-22 06:27:17 EST
COMMIT: http://review.gluster.org/13267 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 90366748a44c853dbba02d6d2a8192643b711017
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jan 20 15:51:41 2016 +0530

    quota: start aux mount from glusterd with inet address
    
    This is a backport of http://review.gluster.org/#/c/13255
    
    With below patches, quota aux mount now
    uses unix domain socket to connect to
    glusterd
    http://review.gluster.org/#/c/12645/
    http://review.gluster.org/#/c/12819/
    
    When USS is enabled, snapd protocol client tries to
    connect to glusterd with inet and fails,
    because remote-host option by client process
    is set to UDS file
    
    This patch starts the aux client process from glusterd
    with inet address
    
    > Change-Id: I6967043bfd8824658ea39bfd2842591fcc3280fd
    > BUG: 1299497
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: Ica512aaf5c2b25f86506bd1e0d7810a8ff1f7632
    BUG: 1300243
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13267
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.