Bug 1300387 - HTTP 404 error on downloading a file after SSA
HTTP 404 error on downloading a file after SSA
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity unspecified
: GA
: 5.6.0
Assigned To: Milan Zazrivec
Satyajit Bulage
ui:smartstate
:
Depends On:
Blocks: 1303101
  Show dependency treegraph
 
Reported: 2016-01-20 11:03 EST by Vadim Rutkovsky
Modified: 2016-06-29 11:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1303101 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:31:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2016-01-20 11:03:20 EST
Description of problem:
Files found after host scanning cannot be downloaded

Version-Release number of selected component (if applicable):
5.5.2.1

How reproducible:
Always

Steps to Reproduce:
1. Add a RHEVM 3.4 provider
2. Set correct credentials for any host
3. Run SmartScan analysis for the host
4. After scanning task is complete open host details
5. Go to Files -> /etc/shadow
6. Click 'Download' link

Actual results:
HTTP 404 error page appears:

"The page you were looking for doesn't exist.

You may have mistyped the address or the page may have moved."


Expected results:
File download starts

Additional info:
File contents is displayed correctly, so probably either incorrect URL generated or httpd doesn't handle the link correctly.

Generated link: https://<cfme url>/host/filesystems/filesystem_download/<file id>
Comment 1 Milan Zazrivec 2016-01-25 08:40:06 EST
Is there perhaps an instance showing this problem? (I cannot reproduce this
on my end).

Thanks.
Comment 3 Shveta 2016-01-27 14:43:37 EST
Assigning to add test case
Comment 4 Milan Zazrivec 2016-02-01 10:33:57 EST
https://github.com/ManageIQ/manageiq/pull/6457
Comment 5 CFME Bot 2016-02-01 16:36:57 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/3b498f4c37066a74929700d01bcb99241327abc1

commit 3b498f4c37066a74929700d01bcb99241327abc1
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Mon Feb 1 16:33:00 2016 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Feb 1 18:20:52 2016 +0100

    Add filesystem_download link to host filesystems page
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300387

 app/controllers/application_controller.rb  | 5 +++++
 app/controllers/vm_common.rb               | 5 -----
 app/views/layouts/_item.html.haml          | 2 +-
 config/routes.rb                           | 1 +
 spec/routing/host_routing_spec.rb          | 6 ++++++
 spec/views/layouts/_item.html.haml_spec.rb | 2 +-
 6 files changed, 14 insertions(+), 7 deletions(-)
Comment 7 CFME Bot 2016-02-15 10:38:36 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 8 Satyajit Bulage 2016-05-18 06:29:18 EDT
Able to download required file(s).

Verified Verison:-5.6.0.7-beta2.6.20160516171555_b1be31f
Comment 10 errata-xmlrpc 2016-06-29 11:31:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.