Bug 1300412 - Data Tiering:Change the default tiering values to optimize tiering settings
Data Tiering:Change the default tiering values to optimize tiering settings
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1283961
Blocks: 1260783 1306302
  Show dependency treegraph
 
Reported: 2016-01-20 12:32 EST by Joseph Elwin Fernandes
Modified: 2016-06-16 09:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283961
: 1306302 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-20 12:33:24 EST
REVIEW: http://review.gluster.org/13270 (tier/dht : Default value for tier-demote-frequency is 3600 sec) posted (#2) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2016-01-20 12:51:08 EST
REVIEW: http://review.gluster.org/13270 (tier/dht : Default value for demote-freq, max files and mb) posted (#3) for review on master by Joseph Fernandes
Comment 3 Vijay Bellur 2016-01-20 21:07:29 EST
REVIEW: http://review.gluster.org/13270 (tier/dht : Default value for demote-freq, max files and mb) posted (#4) for review on master by Joseph Fernandes
Comment 4 Vijay Bellur 2016-01-26 12:16:09 EST
COMMIT: http://review.gluster.org/13270 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit ce2c58d0fab517320059af7cea2e36e5cd246b6e
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Wed Jan 20 22:27:33 2016 +0530

    tier/dht : Default value for demote-freq, max files and mb
    
    Default value for tier-demote-frequency is 3600 sec to avoid
    frequent demotions.
    
    Default value for tier-max-mb is 4000 mb
    
    Default value for tier-max-files is 10000 files
    
    Change-Id: Ie60951c478a7462c425059699ab82511aa13fa0a
    BUG: 1300412
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/13270
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:55:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.