Bug 1306302 - Data Tiering:Change the default tiering values to optimize tiering settings
Data Tiering:Change the default tiering values to optimize tiering settings
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.7
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Joseph Elwin Fernandes
bugs@gluster.org
: Triaged, ZStream
Depends On: 1283961 1300412
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2016-02-10 09:00 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300412
Environment:
Last Closed: 2016-04-19 03:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-10 09:02:10 EST
REVIEW: http://review.gluster.org/13424 (tier/dht : Default value for demote-freq, max files and mb) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2016-02-14 09:08:16 EST
COMMIT: http://review.gluster.org/13424 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 0488cd5683f81eb49636cab59a6a43951e057013
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Wed Jan 20 22:27:33 2016 +0530

    tier/dht : Default value for demote-freq, max files and mb
    
    Default value for tier-demote-frequency is 3600 sec to avoid
    frequent demotions.
    
    Default value for tier-max-mb is 4000 mb
    
    Default value for tier-max-files is 10000 files
    
    Backport of http://review.gluster.org/13270
    
    > Change-Id: Ie60951c478a7462c425059699ab82511aa13fa0a
    > BUG: 1300412
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/13270
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: Ic4458b1b78dc3c6059713f3871e9e2dc8f38b39a
    BUG: 1306302
    Reviewed-on: http://review.gluster.org/13424
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.