Bug 1300637 - Make use of Volume Containers when deploying RHGS pods
Make use of Volume Containers when deploying RHGS pods
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: RHGS 3.1.2
Assigned To: Mohamed Ashiq
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 05:30 EST by Humble Chirammal
Modified: 2016-03-01 00:21 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The data volume container will have all the default volume mounts assigned to it so that it can then be attached to Red Hat Gluster Storage containers. The following option bind mounts all the volumes of the data volume container to the Red Hat Gluster Storage container. --volumes-from <data-volume-container> The data volume container is started along with the setup.sh script. This script moves the backup of gluster configuration file to the expected directories for persistence. Hence, this enhancement simplifies the gluster configuration setup for the Red Hat Gluster Storage container.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:21:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Humble Chirammal 2016-01-21 05:30:06 EST
Description of problem:

Currently the volumes are bind mounted from atomic host as part of RHGS deployment. It would be better if we can deploy data/volume containers and then get the volumes via --volumes-from  <datacontainer>

Version-Release number of selected component (if applicable):

rhgs-server-docker 3.1.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 12 Bhavana 2016-02-26 02:07:23 EST
Hi Ashiq,

The doc text is edited. Please review the same and share your comments. If it looks ok, then do sign-off on the same.
Comment 13 Mohamed Ashiq 2016-02-26 02:38:44 EST
(In reply to Bhavana from comment #12)
> Hi Ashiq,
> 
> The doc text is edited. Please review the same and share your comments. If
> it looks ok, then do sign-off on the same.

looks good to me. Thanks.
Comment 15 errata-xmlrpc 2016-03-01 00:21:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0327.html

Note You need to log in before you can comment on or make changes to this bug.