Bug 1300713 - Tenant Quota enforcement for memory does not work
Tenant Quota enforcement for memory does not work
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.6.0
Assigned To: William Fitzgerald
Aziza Karol
cfme_tenant:provision:quota
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 09:03 EST by Aziza Karol
Modified: 2016-06-29 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:32:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2016-01-21 09:03:33 EST
Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.1.20160114044944_395c086 

How reproducible:
100%

Steps to Reproduce:
1.Navigate to configure->Access control->tenants
2.For Tenant " My Company " enforce Memory quota and set it to 1 GB
3.Provision a infra VM with memory more then 1GB 

Actual results:
Able to provision successfully 

Expected results:
Quota exceeded message should be displayed

Additional info:
Comment 2 Shveta 2016-01-27 14:42:52 EST
Assigning to add test case
Comment 3 William Fitzgerald 2016-01-28 09:59:54 EST
Aziza,

Can you please provide the EVM and Automation logs.
Can you please also provide the appliance information ?

Thanks

Bill
Comment 4 Aziza Karol 2016-01-29 05:06 EST
Created attachment 1119389 [details]
evm log
Comment 5 Aziza Karol 2016-01-29 05:08 EST
Created attachment 1119390 [details]
automation log
Comment 7 William Fitzgerald 2016-01-29 09:06:43 EST
More info in BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=1289278
Comment 8 William Fitzgerald 2016-02-05 15:22:28 EST
please see # https://github.com/ManageIQ/manageiq/pull/6381

I believe this will fix the problem ....
Comment 9 Aziza Karol 2016-04-26 04:53:55 EDT
Tenant Quota enforcement for memory works.

Verified: 5.6.0.4-beta2.3.20160421172650_719e256
Comment 11 errata-xmlrpc 2016-06-29 11:32:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.