Bug 1300809 - filters based on group tag do not give visibility to vms
filters based on group tag do not give visibility to vms
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Libor Pichler
Ramesh A
: ZStream
Depends On:
Blocks: 1304785
  Show dependency treegraph
 
Reported: 2016-01-21 13:57 EST by Felix Dewaleyne
Modified: 2017-01-29 23:57 EST (History)
11 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304785 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:32:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Dewaleyne 2016-01-21 13:57:32 EST
Description of problem:
filters based on group tag do not give visibility to vms

Version-Release number of selected component (if applicable):
5.5.0.13

How reproducible:
all the time

Steps to Reproduce:
1. create a role, group and user
2. set the role to have full visibility with for ownership filter "none"
3. add to the group one of the department tags
4. assign to vms as an admin this tag
5. log out and in as the user
6. access the infrastructure > vm page

Actual results:
no vm is displayed

Expected results:
vms with the tag are displayed

Additional info:
changing the onwership filter to "vms of the group or owned" then altering the vms to be owned by the group or user" will give the visiblity to the vms.
Comment 5 Gregg Tanzillo 2016-02-04 15:43:11 EST
Hi Felix,

I also tried to recreate this both locally and on vm-140.gsslab.fab.redhat.com. On vm-140.gsslab.fab.redhat.com, I created the role, group and user per the instructions above. The group "GT-Group" has the tag department/support set on it. I went and tagged the VM named "6c791d0f-f014-44e8-94a5-c1451111bd2f" with department/support. When I logged in as my new user (gt/smartvm) I was able to only that VM. I left the role, group and user there so you can see it.

Is there something else that needs to be done to see the issue?

Thanks,
Gregg
Comment 6 Harpreet Kataria 2016-02-04 16:31:26 EST
Hi Gregg,

I was not able to recreate this issue locally on master but was able to recreate on the provided environment. You have to apply My Company tags to that group from Policy/Edit Tags screen, not in Group edit Assign Filters section. If you compare GT-Group with  APP_CLOUDFORMS_VOLARB_USER group you will see that group has tags assigned to it, it's not using Tag filters, i have been having issues trying to run 5.5.z locally but could not recreate on latest master code-base.

Let me know if you need help recreating on vm-140.gsslab.fab.redhat.com appliance.

~Harpreet
Comment 7 Felix Dewaleyne 2016-02-05 14:27:40 EST
the environment on vm-140 may have been compromised by me setting ownership on a few vms a while ago to work on another issue that had been raised, I'll continue and look into it monday
Comment 13 Libor Pichler 2016-02-22 02:56:01 EST
https://github.com/ManageIQ/manageiq/pull/6639
Comment 14 CFME Bot 2016-02-23 13:10:59 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 15 CFME Bot 2016-02-25 15:21:00 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 18 CFME Bot 2016-03-01 09:50:41 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 19 CFME Bot 2016-03-01 17:20:34 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/939b09575c0d18732b32a8b0337e83fdcca78711

commit 939b09575c0d18732b32a8b0337e83fdcca78711
Author:     lpichler <lpichler@redhat.com>
AuthorDate: Fri Feb 19 13:32:57 2016 +0100
Commit:     lpichler <lpichler@redhat.com>
CommitDate: Tue Mar 1 15:20:07 2016 +0100

    When tag is deleted, remove it also from group's managed filter
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300809

 app/models/miq_group.rb | 20 ++++++++++++++++++++
 app/models/tag.rb       |  6 ++++++
 2 files changed, 26 insertions(+)
Comment 20 Satyajit Bulage 2016-04-18 05:12:35 EDT
vms with the tag are displayed
Verified version:- 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 22 errata-xmlrpc 2016-06-29 11:32:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.