Bug 1304785 - filters based on group tag do not give visibility to vms
filters based on group tag do not give visibility to vms
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.5.3
Assigned To: Libor Pichler
Aziza Karol
: ZStream
Depends On: 1300809
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 10:42 EST by Chris Pelland
Modified: 2017-08-29 21:40 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, filtering the list of virtual machines by their hosts did not work if the virtual machines also had group tags. This bug was fixed by correcting the filtering code to handle group tags correctly. Virtual machines with group tags can be filtered as expected in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1300809
Environment:
Last Closed: 2016-04-13 14:42:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 CFME Bot 2016-02-25 10:52:53 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=02e1c8ce26b7f3343a8cf5c4ab2c4fcbe31f0db7

commit 02e1c8ce26b7f3343a8cf5c4ab2c4fcbe31f0db7
Merge: 4dff6f6 7522084
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Thu Feb 25 10:25:55 2016 -0500
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Thu Feb 25 10:25:55 2016 -0500

    Merge branch 'bz_1304785' into '5.5.z'
    
    List VMs or Templates when filter for host is assigned
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304785
    
    https://github.com/ManageIQ/manageiq/pull/6639
    
    clean cherry-pick, except to specs:
    added `require "spec_helper"` to `spec/models/miq_filter_spec.rb:1`
    
    and
    
    added
    ```let(:group) { FactoryGirl.create(:miq_group) }
    let(:user)  { FactoryGirl.create(:user, :miq_groups => [group]) }
         ```
    to `spec/models/rbac_spec.rb:239`
    
    See merge request !805

 app/models/miq_filter.rb       | 17 +++++++++----
 app/models/rbac.rb             |  4 ++++
 spec/models/miq_filter_spec.rb | 54 ++++++++++++++++++++++++++++++++++++++++++
 spec/models/rbac_spec.rb       | 24 ++++++++++++++++++-
 4 files changed, 93 insertions(+), 6 deletions(-)
Comment 7 Aziza Karol 2016-03-31 06:06:28 EDT
VMs listed when filter for host is assigned.

Verified:5.5.3.2.20160318152106_92d2d67
Comment 10 errata-xmlrpc 2016-04-13 14:42:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.