Bug 1300955 - CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1301567 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 03:17 EST by masterdead
Modified: 2016-02-01 01:26 EST (History)
9 users (show)

See Also:
Fixed In Version: kernel-4.3.4-300.fc23 kernel-4.3.4-200.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 21:23:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (8.90 KB, text/plain)
2016-01-22 03:17 EST, masterdead
no flags Details
full dmesg (81.39 KB, text/plain)
2016-01-22 03:24 EST, masterdead
no flags Details
dmesg after patched kernel (69.11 KB, text/plain)
2016-01-22 12:36 EST, masterdead
no flags Details

  None (edit)
Description masterdead 2016-01-22 03:17:07 EST
Created attachment 1117131 [details]
lspci

Problem with this warning still persist, across multiple kernel versions 4.2/4.3/4.4 and latest stable kernel 4.3.3-303.fc23.x86_64 which should contains patch for this problem.

Notebook Lenovo t440s, with Intel GPU/CPU, touch display and prodock.

------------[ cut here ]------------
WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Info: mapping multiple BARs. Your kernel is fine.
Modules linked in:

CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.3.3-303.fc23.x86_64 #1
Hardware name: LENOVO 20AR001GXS/20AR001GXS, BIOS GJET86WW (2.36 ) 12/04/2015
 0000000000000000 0000000014cf7e59 ffff880214a1baf8 ffffffff813a625f
 ffff880214a1bb40 ffff880214a1bb30 ffffffff810a07c2 00000000fed10000
 ffffc90000cb8000 0000000000006000 0000000000000000 ffff8800d6381040
Call Trace:
 [<ffffffff813a625f>] dump_stack+0x44/0x55
 [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a085c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff810a6fba>] ? iomem_map_sanity_check+0xba/0xd0
 [<ffffffff81065835>] __ioremap_caller+0x2c5/0x380
 [<ffffffff81065907>] ioremap_nocache+0x17/0x20
 [<ffffffff8103a119>] snb_uncore_imc_init_box+0x79/0xb0
 [<ffffffff81038900>] uncore_pci_probe+0xd0/0x1b0
 [<ffffffff813efda5>] local_pci_probe+0x45/0xa0
 [<ffffffff813f118d>] pci_device_probe+0xfd/0x140
 [<ffffffff814d9b52>] driver_probe_device+0x222/0x480
 [<ffffffff814d9e34>] __driver_attach+0x84/0x90
 [<ffffffff814d9db0>] ? driver_probe_device+0x480/0x480
 [<ffffffff814d762c>] bus_for_each_dev+0x6c/0xc0
 [<ffffffff814d930e>] driver_attach+0x1e/0x20
 [<ffffffff814d8e4b>] bus_add_driver+0x1eb/0x280
 [<ffffffff81d6af1a>] ? uncore_cpu_setup+0x12/0x12
 [<ffffffff814da680>] driver_register+0x60/0xe0
 [<ffffffff813ef78c>] __pci_register_driver+0x4c/0x50
 [<ffffffff81d6affc>] intel_uncore_init+0xe2/0x2e6
 [<ffffffff81d6af1a>] ? uncore_cpu_setup+0x12/0x12
 [<ffffffff81002123>] do_one_initcall+0xb3/0x200
 [<ffffffff810be500>] ? parse_args+0x1a0/0x4a0
 [<ffffffff81d5c1c8>] kernel_init_freeable+0x189/0x223
 [<ffffffff81775c40>] ? rest_init+0x80/0x80
 [<ffffffff81775c4e>] kernel_init+0xe/0xe0
 [<ffffffff81781adf>] ret_from_fork+0x3f/0x70
 [<ffffffff81775c40>] ? rest_init+0x80/0x80
---[ end trace 077c426a39e018aa ]---
Comment 1 masterdead 2016-01-22 03:24 EST
Created attachment 1117133 [details]
full dmesg
Comment 2 Josh Boyer 2016-01-22 08:10:10 EST
(In reply to masterdead from comment #0)
> Created attachment 1117131 [details]
> lspci
> 
> Problem with this warning still persist, across multiple kernel versions
> 4.2/4.3/4.4 and latest stable kernel 4.3.3-303.fc23.x86_64 which should
> contains patch for this problem.

No, it doesn't.  There is a patch that fixes it for a certain class of hardware that is Broadwell based.  Your machine is not Broadwell based, it is Haswell.  

> Notebook Lenovo t440s, with Intel GPU/CPU, touch display and prodock.

I'll try and come up with a kernel for you to test later today.
Comment 3 Josh Boyer 2016-01-22 08:23:05 EST
Please test this kernel when it completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12647895
Comment 4 masterdead 2016-01-22 12:36 EST
Created attachment 1117310 [details]
dmesg after patched kernel
Comment 5 masterdead 2016-01-22 12:37:26 EST
very well, probably fixed.
Comment 6 Josh Boyer 2016-01-22 13:06:02 EST
Thank you for testing.
Comment 7 Fedora Update System 2016-01-25 13:22:17 EST
kernel-4.3.4-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f25d12c51
Comment 8 Fedora Update System 2016-01-25 13:26:02 EST
kernel-4.3.4-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d43766e33
Comment 9 Josh Boyer 2016-01-25 14:35:40 EST
*** Bug 1301567 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2016-01-25 23:22:01 EST
kernel-4.3.4-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d43766e33
Comment 11 Fedora Update System 2016-01-25 23:27:37 EST
kernel-4.3.4-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f25d12c51
Comment 12 Fedora Update System 2016-01-31 21:22:09 EST
kernel-4.3.4-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-02-01 01:22:50 EST
kernel-4.3.4-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.