Bug 1301567 - WARNING: CPU: 2 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
WARNING: CPU: 2 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x...
Status: CLOSED DUPLICATE of bug 1300955
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 07:04 EST by Jan Synacek
Modified: 2016-01-25 14:35 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 14:35:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (72.42 KB, text/plain)
2016-01-25 07:57 EST, Jan Synacek
no flags Details
lspci -nnvv (22.18 KB, text/plain)
2016-01-25 07:58 EST, Jan Synacek
no flags Details

  None (edit)
Description Jan Synacek 2016-01-25 07:04:23 EST
Description of problem:
Every time I boot, I see the following call trace in the logs:

Jan 25 12:56:25 ntb-work kernel: ------------[ cut here ]------------
Jan 25 12:56:25 ntb-work kernel: WARNING: CPU: 2 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Jan 25 12:56:25 ntb-work kernel: Info: mapping multiple BARs. Your kernel is fine.
Jan 25 12:56:25 ntb-work kernel: Modules linked in:
Jan 25 12:56:25 ntb-work kernel: 
Jan 25 12:56:25 ntb-work kernel: CPU: 2 PID: 1 Comm: swapper/0 Not tainted 4.3.3-301.fc23.x86_64 #1
Jan 25 12:56:25 ntb-work kernel: Hardware name: LENOVO 20ARS19C0B/20ARS19C0B, BIOS GJET79WW (2.29 ) 09/03/2014
Jan 25 12:56:25 ntb-work kernel:  0000000000000000 00000000ed3d83c2 ffff8803301a7af8 ffffffff813a626f
Jan 25 12:56:25 ntb-work kernel:  ffff8803301a7b40 ffff8803301a7b30 ffffffff810a07c2 00000000fed10000
Jan 25 12:56:25 ntb-work kernel:  ffffc90001900000 0000000000006000 0000000000000000 ffff88032e4b6300
Jan 25 12:56:25 ntb-work kernel: Call Trace:
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff813a626f>] dump_stack+0x44/0x55
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff810a085c>] warn_slowpath_fmt+0x5c/0x80
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff810a6fba>] ? iomem_map_sanity_check+0xba/0xd0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81065835>] __ioremap_caller+0x2c5/0x380
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81065907>] ioremap_nocache+0x17/0x20
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff8103a119>] snb_uncore_imc_init_box+0x79/0xb0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81038900>] uncore_pci_probe+0xd0/0x1b0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff813efe95>] local_pci_probe+0x45/0xa0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff813f127d>] pci_device_probe+0xfd/0x140
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814d9c42>] driver_probe_device+0x222/0x480
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814d9f24>] __driver_attach+0x84/0x90
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814d9ea0>] ? driver_probe_device+0x480/0x480
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814d771c>] bus_for_each_dev+0x6c/0xc0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814d93fe>] driver_attach+0x1e/0x20
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814d8f3b>] bus_add_driver+0x1eb/0x280
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81d6af1a>] ? uncore_cpu_setup+0x12/0x12
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff814da770>] driver_register+0x60/0xe0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff813ef87c>] __pci_register_driver+0x4c/0x50
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81d6affc>] intel_uncore_init+0xe2/0x2e6
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81d6af1a>] ? uncore_cpu_setup+0x12/0x12
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81002123>] do_one_initcall+0xb3/0x200
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff810be500>] ? parse_args+0x1a0/0x4a0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81d5c1c8>] kernel_init_freeable+0x189/0x223
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81775ae0>] ? rest_init+0x80/0x80
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81775aee>] kernel_init+0xe/0xe0
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff8178195f>] ret_from_fork+0x3f/0x70
Jan 25 12:56:25 ntb-work kernel:  [<ffffffff81775ae0>] ? rest_init+0x80/0x80
Jan 25 12:56:25 ntb-work kernel: ---[ end trace 0ead71c8493fdd59 ]---


Version-Release number of selected component (if applicable):
kernel-4.3.3-301.fc23.x86_64
$ uname -a
Linux ntb-work 4.3.3-301.fc23.x86_64 #1 SMP Fri Jan 15 14:03:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


Steps to Reproduce:
1. Boot.
2. journalctl -b


Actual results:
Weird kernel traces in the logs.


Expected results:
No kernel traces in the logs.
Comment 1 Josh Boyer 2016-01-25 07:23:33 EST
Please attach the output of dmesg and lspci -nnvv
Comment 2 Jan Synacek 2016-01-25 07:57 EST
Created attachment 1117978 [details]
dmesg
Comment 3 Jan Synacek 2016-01-25 07:58 EST
Created attachment 1117979 [details]
lspci -nnvv
Comment 4 Josh Boyer 2016-01-25 14:35:40 EST

*** This bug has been marked as a duplicate of bug 1300955 ***

Note You need to log in before you can comment on or make changes to this bug.