Bug 1301030 - [Snapshot]: Snapshot restore stucks in post validation.
[Snapshot]: Snapshot restore stucks in post validation.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.7
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
: ZStream
Depends On: 1277414 1300979
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 06:32 EST by Avra Sengupta
Modified: 2016-04-19 03:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300979
Environment:
Last Closed: 2016-04-19 03:20:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-29 06:48:33 EST
REVIEW: http://review.gluster.org/13548 (snapshot: Fix parent volinfo corruption in snapshot restore) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-03-11 03:07:15 EST
COMMIT: http://review.gluster.org/13548 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 7ece0b7b04059f79e25cd7bf44218eb4688dd8e3
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jan 22 16:59:53 2016 +0530

    snapshot: Fix parent volinfo corruption in snapshot restore
    
        Backport of http://review.gluster.org/#/c/13282/
    
    Remove parent_volinfo irrespective of success or failure
    of glusterd_lvm_snapshot_remove(). This prevents the
    duplication of the volinfo after the execution of
    glusterd_snapshot_restore().
    
    When commit fails on originator node, we don't perform
    commit on the other nodes, as a result we don't have a
    backup of /var/lib/glusterd/vols/<volname> in the
    GLUSTERD_TRASH in other nodes. But in the postvalidate
    we try to restore from GLUSTED_TRASH and end up cleaning
    up /var/lib/glusterd/vols/<volname>. Hence moved
    glusterd_snapshot_backup_vol() from commit to prevalidate,
    so that the backup is always available when a cleanup is
    needed.
    
    Change-Id: Icd471b23faf02bad680b9a1aadc4a0175f7cce8b
    BUG: 1301030
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13282
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    (cherry picked from commit 3f78b6b3dc6376945a1b1a7c4af16103901ab746)
    Reviewed-on: http://review.gluster.org/13548
Comment 3 Kaushal 2016-04-19 03:20:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.