Bug 1301190 - Catalog Item : Unable to assign catalog to bundle
Catalog Item : Unable to assign catalog to bundle
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Shveta
service:catalog
: ZStream
Depends On:
Blocks: 1302015
  Show dependency treegraph
 
Reported: 2016-01-22 15:15 EST by Shveta
Modified: 2016-06-29 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302015 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:32:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog (108.90 KB, image/png)
2016-01-22 15:15 EST, Shveta
no flags Details
err (91.04 KB, image/png)
2016-01-22 15:16 EST, Shveta
no flags Details

  None (edit)
Description Shveta 2016-01-22 15:15:59 EST
Created attachment 1117332 [details]
catalog

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a catalog bundle. Try to assign catalog in the catalog drop down 
2. No error , but catalog doesn't get assigned .
3.

Actual results:


Expected results:


Additional info:
5.5.2.1.20160114044944_395c086
Comment 2 Shveta 2016-01-22 15:16 EST
Created attachment 1117333 [details]
err
Comment 3 Harpreet Kataria 2016-01-25 11:42:45 EST
https://github.com/ManageIQ/manageiq/pull/6326
Comment 4 CFME Bot 2016-01-25 18:31:03 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/204f3b834c05bd8e4e56c41915523ddd4df01442

commit 204f3b834c05bd8e4e56c41915523ddd4df01442
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 25 10:56:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 25 10:56:27 2016 -0500

    Changes to set catalog for Catalog Bundle even if display is not set
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301190

 app/controllers/catalog_controller.rb | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
Comment 5 CFME Bot 2016-01-25 18:31:12 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/0934a186313ab106bcff09fed0409754ffb30ace

commit 0934a186313ab106bcff09fed0409754ffb30ace
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 25 11:30:37 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 25 16:48:24 2016 -0500

    Refactored common code into single method.
    
    Added spec test for the fix.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301190

 app/controllers/catalog_controller.rb       | 20 ++++++++++----------
 spec/controllers/catalog_controller_spec.rb | 25 +++++++++++++++++++++++++
 2 files changed, 35 insertions(+), 10 deletions(-)
Comment 6 CFME Bot 2016-01-26 19:02:27 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=68b7cd747de5a5700ba8a4b180e09d33c426c8df

commit 68b7cd747de5a5700ba8a4b180e09d33c426c8df
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 25 10:56:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Jan 26 17:45:38 2016 -0500

    Changes to set catalog for Catalog Bundle even if display is not set
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301190
    https://bugzilla.redhat.com/show_bug.cgi?id=1302015
    (cherry picked from commit 204f3b8)

 app/controllers/catalog_controller.rb | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
Comment 7 CFME Bot 2016-01-26 19:02:39 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=637cf49b532ff4bb947d804228ab4b514f786b73

commit 637cf49b532ff4bb947d804228ab4b514f786b73
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 25 11:30:37 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Jan 26 17:45:38 2016 -0500

    Refactored common code into single method.
    
    Added spec test for the fix.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301190
    (cherry picked from commit 0934a18)

 app/controllers/catalog_controller.rb       | 20 ++++++++++----------
 spec/controllers/catalog_controller_spec.rb | 25 +++++++++++++++++++++++++
 2 files changed, 35 insertions(+), 10 deletions(-)
Comment 8 CFME Bot 2016-02-11 11:03:00 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a7c5d806df828a3b1e78f5107ab6d9ec0727b1ce

commit a7c5d806df828a3b1e78f5107ab6d9ec0727b1ce
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 25 10:56:27 2016 -0500
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Feb 1 14:03:28 2016 +0100

    Changes to set catalog for Catalog Bundle even if display is not set
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301190
    https://bugzilla.redhat.com/show_bug.cgi?id=1302015
    (cherry picked from commit 204f3b8)

 app/controllers/catalog_controller.rb | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
Comment 9 CFME Bot 2016-02-11 11:03:28 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f79aa7c79e6d65ae4876e104d30ae02e8b478f79

commit f79aa7c79e6d65ae4876e104d30ae02e8b478f79
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 25 11:30:37 2016 -0500
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Feb 1 14:03:28 2016 +0100

    Refactored common code into single method.
    
    Added spec test for the fix.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301190
    (cherry picked from commit 0934a18)

 app/controllers/catalog_controller.rb       | 20 ++++++++++----------
 spec/controllers/catalog_controller_spec.rb | 25 +++++++++++++++++++++++++
 2 files changed, 35 insertions(+), 10 deletions(-)
Comment 10 Shveta 2016-04-18 15:12:41 EDT
verification Blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1328230
Comment 11 Shveta 2016-04-22 17:20:50 EDT
Fixed . 
verified in 

5.6.0.4-beta2.3.20160421172650_719e256
Comment 13 errata-xmlrpc 2016-06-29 11:32:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.