Bug 1301326 - windows xp guest is not updated with values in the sysprep file
windows xp guest is not updated with values in the sysprep file
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Shahar Havivi
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 03:29 EST by Ilanit Stein
Modified: 2016-02-07 09:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-07 09:21:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
istein: planning_ack?
istein: devel_ack?
istein: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2016-01-24 03:29:35 EST
Description of problem:
run once a VM created from windows xp template, sealed with mini setup.
On the run once dialog, in sysprep field, paste sysprep.ini, with values for computer name and product key.
Inside the guest, looking at the floppy content,
the sysprep.ini indeed contain same content, as put in the sysprep field,
but the values seem to not implemented in the guest (computer name, or prduct key - that was still requested).


Version-Release number of selected component (if applicable):
rhevm 3.6.2-10

How reproducible:
always
Comment 1 Ilanit Stein 2016-01-24 05:29:30 EST
Additional info:
Sealing windows xp template was done by this procedure:

3.6-Beta/html/Virtual_Machine_Management_Guide/sect-Sealing_Virtual_Machines_in_Preparation_for_Deployment_as_Templates.html

Procedure 6.11. Sealing a Windows XP Template

Download sysprep to the virtual machine to be used as a template.
The Windows XP Sysprep tool is available at http://www.microsoft.com/download/en/details.aspx?id=11282
Create a new directory: c:\sysprep.
Open the deploy.cab file and add its contents to c:\sysprep.
Execute sysprep.exe from within the folder and click OK on the welcome message to display the Sysprep tool.
Select the following check boxes:
Don't reset grace period for activation
Use Mini-Setup
Ensure that the shutdown mode is set to Shut down and click Reseal.
Acknowledge the pop-up window to complete the sealing process; the virtual machine shuts down automatically upon completion.
The Windows XP template is sealed and ready for deploying virtual machines.
Comment 2 Michal Skrivanek 2016-02-02 06:32:39 EST
since the variables are substituted it looks like a windows problem. I find it weird that it wouldn't work at all...are you sure you used a correct template? what's the difference from the stock one?
Comment 3 Ilanit Stein 2016-02-03 07:48:27 EST
I used a template, I created from a VM, after sealing it, following the  Virtual_Machine_Management_Guide.
What do you mean please by "stock one"?
Comment 4 Michal Skrivanek 2016-02-03 09:15:06 EST
from the "paste sysprep.ini" I inferred you were using the custom script. Is it not the case?
Comment 5 Ilanit Stein 2016-02-03 09:32:15 EST
oh I now understand what you've meant.
The template used from the engine directory (stock) was correct.
The difference from the stock is that I've replaced computer name, and product key values. I agree it sound like a problem in the guest side, as these 2 values do exist in the sysprep.ini floppy attached to the guest.
Comment 6 Michal Skrivanek 2016-02-03 09:35:22 EST
potentially a duplicate of bug 1301368
Comment 7 Ilanit Stein 2016-02-07 09:21:38 EST
Closing the bug, further to bug 1302722 - 
"[Docs] Remove the support statement for Windows versions that are out of support by Microsoft"

Note You need to log in before you can comment on or make changes to this bug.