This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1301447 - [Docs][RFE][Upgrade] Document the in-cluster upgrade feature
[Docs][RFE][Upgrade] Document the in-cluster upgrade feature
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity unspecified
: ovirt-3.6.6
: ---
Assigned To: Byron Gravenorst
Tahlia Richardson
http://www.ovirt.org/feature/incluste...
: FutureFeature
Depends On: 1241149
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 00:25 EST by Lucy Bopf
Modified: 2016-05-26 21:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 21:03:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucy Bopf 2016-01-25 00:25:33 EST
The in-cluster upgrade feature will allow users to upgrade RHEL 6 hosts in a RHEL 6 cluster to RHEL 7, without the need for the workaround described in https://access.redhat.com/articles/1390733

See http://www.ovirt.org/Features/InClusterUpgrade#InClusterUpgrade for more information on the implementation of this feature.
Comment 2 Lucy Bopf 2016-03-08 06:23:45 EST
Retargeted to match the engineering bug's target milestone.
Comment 4 Lucy Bopf 2016-04-26 02:37:43 EDT
Assigning to Byron for review.
Comment 7 Artyom 2016-05-15 07:36:29 EDT
Some corrections:
1) http://file.bne.redhat.com/~bgraveno/1301447/doc-Upgrade_Guide/Upgrading_a_Red_Hat_Enterprise_Linux_6_Cluster_to_Red_Hat_Enterprise_Linux_7.html
 * No virtual machines with the migration option
   "Do not allow migrations" or "Allow manual migration only" selected.
 * Also you do not allow to create or update VM with above migration options
   when InClusterUpgrade policy enabled.
 * After you finish install of RHEL7 on host, you need to fetch new SSH 
   fingerprint(Host->Edit->General->Advanced Parameters->fetch) and reinstall
   host via engine(Host->Reinstall)
 * RHEV-H upgrade for major versions not supported via engine, so you need
   to install RHEV-H7 on the host or via PXE or via USB-key and after
   installation finish, you must do the same steps as for RHEL
   (fingerprint and reinstall)

2) http://file.bne.redhat.com/~bgraveno/1301447/doc-Self_Hosted_Engine_Guide/Upgrading_the_Self-Hosted_Engine_from_6_to_7.html
 * No virtual machines with the migration option
   "Do not allow migrations" or "Allow manual migration only" selected.
 * I believe we have some problem in flow:
   1) Upgrade engine VM to 3.6(global maintenance, correct repos,
      yum update, engine-setup) and do not update hosts
      (because hosts still RHEL6)
   2) Enable InClusterUpgrade policy
   3) Start upgrade of hosts(like you described under  Upgrading Red Hat
      Enterprise Linux 6 Hosts to 7 Hosts in the Red Hat Enterprise 
      Virtualization 3.6 Environment)

Note You need to log in before you can comment on or make changes to this bug.