Bug 1301482 - Server now managed event is not emitted when a osd node is added to a cluster.
Server now managed event is not emitted when a osd node is added to a cluster.
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Linux
unspecified Severity high
: rc
: 2.0
Assigned To: Gregory Meno
ceph-qe-bugs
:
Depends On:
Blocks: 1291304
  Show dependency treegraph
 
Reported: 2016-01-25 03:36 EST by Darshan
Modified: 2016-02-19 13:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 13:34:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darshan 2016-01-25 03:36:07 EST
Description of problem:
Event will not be emitted when a osd node is added to the cluster. However when a new monitor node is added to a cluster an event is emitted by calamari. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add a osd node to an existing cluster
2. add a mon node to an existing cluster
3.

Actual results:
An event is emitted by calamari indicating addition of only mon node to the cluster.

Expected results:
Event has to be emitted even when a osd node is added to a cluster.

Additional info:
Comment 3 Gregory Meno 2016-01-29 12:48:49 EST
This bug is going to require a different approcach that calamari previously could take. We won't be able to give "OSD now managed" the best we can offer is "ceph knows about OSD.N"

The reason is because calamari isn't running on the OSDs previously when our salt-minion agent connected to the master we could emit an event like this.

Now this is responsibility for rhs-controler-agent to offer a generic host managed and calamari could observe and correlate to OSD

So this is either Won't fix or depends on getting a generic event for rhs-controller-agent and mapping it
Comment 4 Dusmant 2016-02-02 04:06:59 EST
Did the earlier Calamari code had this capability, which was sitting on an OSD? If so, we can plan using the similar capability in RHS Controller agent.
Comment 5 Darshan 2016-02-03 05:03:07 EST
Okay, we can get this information as part of osd and mon add/removed events . I raised this bug as this seemed to be working before (in calamari master branch). Now in calamari-lite if its not possible to track this its fine.
Comment 6 Federico Lucifredi 2016-02-19 13:34:08 EST
Calamari does not know about this, hence it cannot event.

Note You need to log in before you can comment on or make changes to this bug.