Bug 130159 - FC3test1 Kernel Oops during boot on i865G/P4 PC
FC3test1 Kernel Oops during boot on i865G/P4 PC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-08-17 12:20 EDT by Bevis King
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 21:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2004-08-17 12:20:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Fedora Core 3 test 1 installs fine off CD-ROM; after reboot the kernel
immediately panics with a Kernel Oops.  Install CD kernel ran fine.
Machine is a Viglen Genie Pentium-4 machine based on the intel i865G
chipset (intel D865GLC motherboard, Pentium-4 2.8E GHz (800MHz FSB),
512MB DDR400 RAM).

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.478smp

How reproducible:
Always

Steps to Reproduce:
1.  Install Fedora Core 3 test 1
2.  Boot from HD
3.
    

Actual Results:  Kernel oops at very early stage of boot.  Machine
never usable.

Expected Results:  Kernel boots...

Additional info:

The following is the output (written down by hand, but checked
carefully against printout before clearing):

init /boot/init-2.6.7-1.478smp.img
     [Linux-initrd @ 0x1eef1000, 0x2e654 bytes]

Uncompressing Linux.... OK, booting the kernel
ACPI: S3 and PAE do not like each other for now, S3 disabled
Unable to handle kernel NULL pointer dereference at virtual address
00000008
printing eip:
*pde = 00003001
Oops:  0000 [#1]
SMP
Modules linked in:
CPU:     1
EIP:     0060:[<00000008>]  Not tainted
EFLAGS:  00010202   (2.6.7-1.478smp)
EIP is at 0x8
eax: 00000000   ebx: 00000000    ecx: 00000000    edx: 00000000
esi: 000003e8   edi: 021c4e55    edp: 021cdfd4    esp: 20ebaf9c
ds:  0060       es:  0287        ss:  0068
Process swapper: (pid: 1, threadinfo=20eba000 task=20e8b730)
Stack: 00000001  021d8c0c  00000000  00000000  00000000  021d1dfb 
00000000  021e27ee
       023ae028  0239b64e  000000f4  02436c40  0239b72b  023897ea 
023ff1ec  00000000
       021004dd  00000000  00000000  02100419  00000000  021041f1 
00000000  00000000
Call Trace:
[<021d8c0c>]<1>Unable to handle kernel NULL pointer dereference
Comment 1 Bevis King 2004-09-06 10:20:56 EDT
I've just seen an identical fault (same EIP etc) on an Intel i875PBZ
based motherboard.  Really not having much luck with these intel
chipsets and Fedora Core 3 test 1.  I'm currently trying the 2.6.8-520
kernel on that machine....
Comment 2 Bevis King 2004-09-07 06:51:33 EDT
Added Kernel 2.6.8-520 to the kickstart install and once rekicked it
now boots correctly and normally on the i875PBZ machine; however the
system remains unusable due to bug #130004 (NFS client Oops).
Comment 3 Ronny Buchmann 2004-10-19 16:40:50 EDT
please close this bug
Comment 4 Dave Jones 2005-07-15 13:39:17 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Bevis King 2005-07-21 06:43:16 EDT
As mentioned in comment #2, the 2.6.8-520 kernel fixed this bug.  The machines
concerned are currently operational with production FC3 with no problems.

Note You need to log in before you can comment on or make changes to this bug.