This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 130161 - Anaconda fails to mount vfat parition and bails out
Anaconda fails to mount vfat parition and bails out
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 128919 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-17 12:27 EDT by Oded Arbel
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 12:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2004-08-17 12:27:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
If I create a windows partition and assign it a mount point (which I must do as otherwise Disk Druid complains), then the installation procedure formats the parition (or not, doesn't matter) and then tries to mount it.

The following errors can be found on console 4:
<4>Unable to load NLS charse ascii
<3>FAT: IO charset ascii not found

And this is on console 3:
* trying to mount hda2 on /mnt/windows
* isys.py:mount()- going to mount /tmp/hda2 on /mnt/sysimage/mnt/windows

On the X screen the following error is then displayed:
Error mounting device hda2 as /mnt/windows: Invalid argument
This most likely means this parition has not been formatted.
Press OK to reboot your system.

I labeled this bug as High priority as its is effectivly prevent me from installing Fedora Core unless I either give up on installing a dual boot system or play with Disk Druid until it lets me leave an empty un partitioned space at the start or middle of the disk and format it later (something I think cannot be done currently - see bug 130156)

Version-Release number of selected component (if applicable):
fedora core 3 - test 1

How reproducible:
Always

Steps to Reproduce:
1. install fedora core
2. create a vfat partition (mount it under /mnt/windows or something)
3. mark vfat partition to be formatted
3. create a couple of other paritions.
4. start the instlation


Actual Results:  The above error will be displayed and the system will then reboot with no options of continuing the installation

Expected Results:  The installation procedure should succesfuly mount the windows partition and continue to install package, or - at the least offer the option of ignoring the error and continuing normally (who needs the windows parition while installing linux anyway ? I only create it to install windows later)

Additional info:
Comment 1 Jeremy Katz 2004-08-17 12:49:22 EDT
Kernel bug, fixed with newer kernels.
Comment 2 Jones Lee 2004-08-18 07:17:01 EDT
*** Bug 128919 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.