Bug 1301631 - Cannot not approve VM provision requests in the UI
Cannot not approve VM provision requests in the UI
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Keenan Brock
Niyaz Akhtar Ansari
: ZStream
Depends On:
Blocks: 1301714
  Show dependency treegraph
 
Reported: 2016-01-25 09:58 EST by Kevin Morey
Modified: 2016-06-29 11:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1301714 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:33:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (329.90 KB, application/pdf)
2016-01-25 09:58 EST, Kevin Morey
no flags Details

  None (edit)
Description Kevin Morey 2016-01-25 09:58:58 EST
Created attachment 1118063 [details]
screenshots

Description of problem:
I ran into this issue last week and can reproduce it in my lab. When a provision request is not auto-approved and requires manual approval there is no way to approve the request without going into the rails console or someway via automate. This is affecting POC's out in the field.

Version-Release number of selected component (if applicable):
5.5.2.1

How reproducible:
100%

Steps to Reproduce:
1. Create a vm provision request that does not get auto-approved as a user
2. Log into Admin and click on the request


Actual results:
The approve / deny check boxes do not appear.

Expected results:
The approve / deny check boxes should be available.

Additional info:
Screenshots are attached. Appliance information where i have reproduced this issue will follow
Comment 9 CFME Bot 2016-01-26 15:06:20 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/a94ead3f708c486e8405049d21bfec85cdd03df3

commit a94ead3f708c486e8405049d21bfec85cdd03df3
Author:     Keenan Brock <kbrock@redhat.com>
AuthorDate: Tue Jan 26 11:09:31 2016 -0500
Commit:     Keenan Brock <kbrock@redhat.com>
CommitDate: Tue Jan 26 11:47:06 2016 -0500

    FIX: Approve Vm provisioning in UI
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301631
    
    The workflow requester is set to the current_user.
    The group context for the request was then being set in the the
    current_user, corrupting it.
    
    Changes:
    
    1. MiqRequestWorkflow#requester = MiqRequest#requester
    so the correct dialogs will be displayed.
    2. Requester is cloned before setting the group as a precaution.
    
    This assumes the viewer and administrator can see the resources that
    the requester has access to view as well.

 app/controllers/application_controller/miq_request_methods.rb | 2 +-
 app/models/miq_request_workflow.rb                            | 6 +++++-
 2 files changed, 6 insertions(+), 2 deletions(-)
Comment 11 CFME Bot 2016-01-26 19:37:29 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=35fd2d3d6403493a8411c7250944007a6586ab9b

commit 35fd2d3d6403493a8411c7250944007a6586ab9b
Author:     Keenan Brock <kbrock@redhat.com>
AuthorDate: Tue Jan 26 11:09:31 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Jan 26 18:29:49 2016 -0500

    FIX: Approve Vm provisioning in UI
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301631
    
    The workflow requester is set to the current_user.
    The group context for the request was then being set in the the
    current_user, corrupting it.
    
    Changes:
    
    1. MiqRequestWorkflow#requester = MiqRequest#requester
    so the correct dialogs will be displayed.
    2. Requester is cloned before setting the group as a precaution.
    
    This assumes the viewer and administrator can see the resources that
    the requester has access to view as well.

 app/controllers/application_controller/miq_request_methods.rb | 2 +-
 app/models/miq_request_workflow.rb                            | 6 +++++-
 2 files changed, 6 insertions(+), 2 deletions(-)
Comment 12 CFME Bot 2016-02-11 11:03:51 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3b47a34e891dfac185f23fe6f583e36fe2a01c88

commit 3b47a34e891dfac185f23fe6f583e36fe2a01c88
Author:     Keenan Brock <kbrock@redhat.com>
AuthorDate: Tue Jan 26 11:09:31 2016 -0500
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Feb 1 14:03:29 2016 +0100

    FIX: Approve Vm provisioning in UI
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301631
    
    The workflow requester is set to the current_user.
    The group context for the request was then being set in the the
    current_user, corrupting it.
    
    Changes:
    
    1. MiqRequestWorkflow#requester = MiqRequest#requester
    so the correct dialogs will be displayed.
    2. Requester is cloned before setting the group as a precaution.
    
    This assumes the viewer and administrator can see the resources that
    the requester has access to view as well.

 app/controllers/application_controller/miq_request_methods.rb | 2 +-
 app/models/miq_request_workflow.rb                            | 6 +++++-
 2 files changed, 6 insertions(+), 2 deletions(-)
Comment 13 Niyaz Akhtar Ansari 2016-04-20 03:45:01 EDT
The approve / deny check boxes is available
verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 15 errata-xmlrpc 2016-06-29 11:33:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.