Bug 1301660 - ISO provisioning always fails because it can't start the VM while the disk is locked
ISO provisioning always fails because it can't start the VM while the disk is...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
All All
high Severity medium
: GA
: 5.5.3
Assigned To: Drew Bomhof
Shveta
: ZStream
Depends On: 1298748 1301662
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 10:49 EST by Drew Bomhof
Modified: 2016-04-13 14:41 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
When provisioning from an ISO in Red Hat CloudForms 4.0, the automation state machine previously exited with an oVirt error reporting locked disks. This was caused due to the destination_image_locked? method only being called on native Red Hat Enterprise Virtualization provisioning. This release adds a destination_image_locked? check for all Red Hat Enterprise Virtualization ISO and PXE provisioning.
Story Points: ---
Clone Of: 1298748
Environment:
Last Closed: 2016-04-13 14:41:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-02-10 14:54:54 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8dae5301ab421df2303ac37c75a34f4892c4a2fe

commit 8dae5301ab421df2303ac37c75a34f4892c4a2fe
Merge: 0b8f8d7 d547fbc
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Feb 10 14:28:56 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Feb 10 14:28:56 2016 -0500

    Merge branch '5.5.z_cannot_provision_iso' into '5.5.z'
    
    Added destination_image_locked? check to RHEV iso/pxe provisioning
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301660
    
    The destination_image_locked? method was only being
    called on native RHEV provisioning.  This change slightly
    refactors the customize_destination method to enable
    the destination_image_locked? check for all RHEV
    provisioning types
    
    PR: https://github.com/ManageIQ/manageiq/pull/6251
    
    Cherry Pick was not clean. Conflicts showed up in spec ..infra_manager/provision/state_machine_spec.rb
    
    See merge request !747

 .../infra_manager/provision/state_machine.rb       |  9 +++--
 .../provision_via_iso/state_machine.rb             |  8 +---
 .../provision_via_pxe/state_machine.rb             |  7 +---
 .../infra_manager/provision/state_machine_spec.rb  | 44 ++++++++++++----------
 .../provision_via_iso/state_machine_spec.rb        | 15 +++++---
 .../provision_via_pxe/state_machine_spec.rb        | 29 ++++++++++++++
 6 files changed, 72 insertions(+), 40 deletions(-)
Comment 4 Shveta 2016-03-29 19:49:33 EDT
Tested ISO provisioning . No disc locked error observed in logs .
Provisioning failed due to other ISO bug https://bugzilla.redhat.com/show_bug.cgi?id=1316735

Verified in 5.5.3.2.20160318152106_92d2d67
Comment 6 errata-xmlrpc 2016-04-13 14:41:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.